1

I bought a couple of "ESP8266-Pro" micro-controllers from a Chinese company named RobotDyn. There's no real documentation with them, but I've bought a lot of other stuff from them in the past that worked out really well, so I took a chance.

After some work, I am finally able to program the board with the Arduino IDE 1.8.1.

The problem is that I am unable to get the serial monitor working to see what's going on with the code.

What do I need to do to get this to work, or is it simply not possible? In order to program the board, I need to connect EN to VIN, and both IO0 and IO15 to GND. I assume I have to disconnect that to actually run the board after programming, but I don't know and haven't gotten anything to work yet.

Here's a photo of the board hooked up for programming. What do I need to do to restart it with the serial monitor working?

RobotDyn ESP8266-Pro connected for programming with CP2102

2
  • scroll down robotdyn.com/catalog/boards/wifi_module_esp8266_pro_8m_flash
    – Juraj
    Dec 10 '17 at 19:47
  • I've seen those before. First place I looked. But none of them answer my question in a way I understand, at least. If one of those three docs explain how to connect serially, I'd appreciate it if you explained, more specifically, what I'm not grokking. Dec 10 '17 at 21:07
1

You applied connections like it was a plain esp8266. The board has the necessary pull-ups and pull-downs. Connect it at first only to GND, VCC, TX, RX. The button pulls gpio0 LOW to enter flashing mode at power up.

2
  • I'll try just those 4 pins, thanks. But I'm pretty sure I started with that and got nowhere. I'll respond with results later. Dec 10 '17 at 21:09
  • As I thought, I had tried this. Does not work as you expected. I consistently get the following errors from the IDE when it attempts uploading: warning: espcomm_sync failed, error: espcomm_open failed, error: espcomm_upload_mem failed, error: espcomm_upload_mem failed. As I say here (stackoverflow.com/a/47742473/1480995), I am unable to program unless IO15 and IO0 are grounded and EN is run to VIN, regardless of the use of the button. Dec 10 '17 at 22:56
0

So it seems that the trick to being able to monitor serial output on the RobotDyn ESP8266-Pro is to NOT have DTR and CTS from the CP2102 programmer connected to the board's RST and IO12 pins.

With only the four remaining lines connected (VCC, GND, TXO, and RXI), you will see normal serial output on the the Arduino IDE's serial monitor after uploading firmware completes.

This works for me with the board set as "Generic ESP8266 Module" or as "NodeMCU 1.0 (ESP-12E Module)".

This still doesn't get you serial monitoring when you just plug in the device, though. It only works after firmware has been uploaded. Still working on that.

2
  • without DTR signal the Serial Monitor doesn't restart the board as you know it from Arduino
    – Juraj
    Dec 11 '17 at 7:49
  • OK, I'll look into that. I'm not familiar with these serial devices at all - everything I've used had built-in USB except from an Arduino Pro-Min that worked with the programmer cable I got with my CP2102 out of the box. Dec 11 '17 at 12:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.