I think my question is quite specific to High Sierra. I am very new and have bought a starter Elegoo kit to learn the basics. I did not realise that their boards are not the real thing.

I have an iMac running High Sierra and although the Mac recognises the board (I checked this through the apple menu) every time i try to upload code i get the error message:

avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00

I have watched several videos on line that have taken me through installing drivers including one specific to High Sierra. However the problem continues.

Does anyone know if i buy a genuine Arduino board, will i have the issues? Will Arduino just not work with High Sierra.

Any help or advice would be so appreciated by someone very new and trying to learn!

Thank you


  • 1
    Does the board use the CH340G USB chip?
    – Majenko
    Commented Dec 9, 2017 at 12:40
  • By looking. Read the chip numbers.
    – Majenko
    Commented Dec 9, 2017 at 12:44
  • 2
    Do you even know what a chip is? You're looking at capacitors there. Chips. They're black, either square or rectangular, sometimes with metal pins sticking out the sides.
    – Majenko
    Commented Dec 9, 2017 at 12:55
  • 1
    Does anything work with High Sierra? With all the bad press it's been getting recently I am surprised they haven't pulled it ;)
    – Majenko
    Commented Dec 9, 2017 at 13:07
  • 1
    You need to learn two separate spheres of knowledge - electronics and programming. Start by learning about simple circuits and how electronics function - separate to Arduino. Then learn basic programming techniques (again not necessarily related to Arduino) and then fit the two together.
    – Majenko
    Commented Dec 9, 2017 at 13:15

3 Answers 3


From reading both your questions, I'm not sure whether you've gotten your board to upload yet.

But here's another data point: I just tried an Arduino Mega r2 and iMac with High Sierra - worked perfectly, first try. Arduino IDE 1.6.12.

In your other question, you said you were getting a solid green LED and a blinking yellow one. The green LED is the power LED. The yellow one is programmable so it sounds like the Blink sketch is already loaded and running.

If you're still getting upload errors, check the Arduino IDE Tools menu and check you hardware selections in the Arduino IDE Tools menu. Here are mine; your /dev/cu.usbmodemxxx number might be different but there should only be one of those if you only have one Arduino plugged in:

enter image description here

  • that was it, i think it is probably my fault for religiously following the instructions sent me by Elegoo that told me to select the Arduino Genuino and i did not see the option to select the board as Mega 2560! I guess you live and learn... thank you so much for your advice. I feel a bit stupid no that it was such a simple solution! Thank you again
    – Paddy
    Commented Dec 11, 2017 at 11:53

As long as the firmware on the ATMega16U2 chip is the same as on a Genuine Arduino and the bootloader on the ATMega2560 chip is the same as on a Genuine Arduino then your boards should function exactly the same as a Genuine Arduino.

If you find a Genuine Arduino works but your boards don't then there must be a difference, and that can really only be in the software on the chips - so reprogramming the chips to match a Genuine Arduino would probably help.

I haven't heard reports of High Sierra not working with Genuine Arduino boards, but given the severity of some of the bugs that have crept in recently, it seems likely that more problems are hidden away under the hood that no one really knows about yet.


I use High Sierra on my ageing 2011 MacBook and it works with reputable Arduino clones (it is difficult to get a genuine Arduino in Australia, although compatible Freetronics boards are available from a major retailer).

There were some problems with ARDUINO 1.8.4 but the latest works flawlessly.

Anything with a CH340G chip is out, but then the CH340G don't seem to last anyway.

  • thank you. I realised i was being very stupid and had not selected the right board. I feel and idiot but hopefully have learnt not to follow instructions too carefully in future. Thank you so much for you help
    – Paddy
    Commented Dec 11, 2017 at 11:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.