I ordered a 128x64 pixel OLED display from Adafruit and wired it according to their guide. (To an Arduino Uno) I'm using SPI right now and the display will not turn on or do anything. I haven't tried i2C, but I don't think that should make a difference. Maybe I will if nothing else works. I've installed the two libraries from the guide and am running the SPI 128x64 example. I've tried to find people with this same issue but I haven't found that much about it. Any help would be greatly appreciated!

Edit: Added pictures. I've used header pins in the past in case anyone is wondering if the connection using these wires isn't good, but the pins did not work either, so it's not a bad connection.

enter image description here enter image description here

  • There isn't exactly a question here that has a definite answer. A clear photograph of your setup would help. Please state the exact part number you are using, also the exact sketch that you are testing it with.
    – Nick Gammon
    Dec 9, 2017 at 3:14
  • The sketch is an example from the SSD1306 library called "ssd1306_128x64_spi". I will add a picture soon. Dec 9, 2017 at 4:59
  • 2
    I don't see any soldering in those pictures. You can't just poke wires into holes and hope they'll work. That will be your problem.
    – Nick Gammon
    Dec 9, 2017 at 6:41
  • 4
    and wired it according to their guide - No you didn't. See the this - you didn't solder the pins to the board.
    – Nick Gammon
    Dec 9, 2017 at 6:46
  • I understand that, but I've done this with a few different sensors in the past and as long as the wires are touching the metal holes there is a connection. I also have set it up exactly how they showed it in the guide just without soldering it. Dec 9, 2017 at 16:51

3 Answers 3


Wiring is your problem. Use soldering iron/solder and flux. Solder your wires. Intermittent connections and accidental shortages with current setup may damage your Arduino and display (and possible your PC/laptop).


I know this issue and understand it well.

If the module is genuine from Adafruit then it should definitely work, if not then once try this library https://github.com/olikraus/U8glib_Arduino

This library has very good documentation. Further if it does not work, attach the picture of wiring.


Its not every time fault of hardware, check the program as well. Load example test program and try again. https://iotforgeeks.com/i2c-oled-display-not-working/ helped me to resolve the same issue.

Not the answer you're looking for? Browse other questions tagged or ask your own question.