I was programing the arduino and things were going great. Then I plugged in another chip, and went to burn a boot loader. (New chips) now, I get:

avrdude: usbdev_open(): did not find any USB device "usb"

when I try to upload code to old chips, I get:

avrdude: usbdev_open(): did not find any USB device "usb"

ten times. I have tried reseting, and it doesnt do anything. when I plug the device in,

dmesg shows that the device responds to my PC

[526199.130716] usb 3-1: new full-speed USB device number 7 using xhci_hcd
[526199.149422] usb 3-1: New USB device found, idVendor=2341, idProduct=0043
[526199.149427] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=220
[526199.149430] usb 3-1: Manufacturer: Arduino (www.arduino.cc)
[526199.149433] usb 3-1: SerialNumber: 649343332353518022F0
[526199.149579] usb 3-1: ep 0x82 - rounding interval to 1024 microframes, ep desc says 2040 microframes
[526199.149766] cdc_acm 3-1:1.0: ttyACM0: USB ACM device

IDE settings: board: Audruino Uno serial posrt /dev/ttyACM0 Programer: AVRISP mkII

I also tried AVR ISP

in the command line, I tried:

   avr-gcc -DF_CPU=16000000UL -mmcu=atmega328 -o Balls.out Balls.c
   avr-objcopy -O ihex -R .eeprom Balls.out  Balls.hex
   sudo avrdude -V -F -c stk500v1 -p m328 -b 19200 -P /dev/ttyACM0 -U flash:w:Balls.hex

each time, I get:

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00

How can I troubleshoot the Arduino Uno? Is this thing broken?

  • You (or your IDE) are using the wrong command line arguments for an Arduino UNO - although connected via USB, as far as avrdude is concerned it is a serial device, not a USB one. In the case of your linux box, the first one connected appears to be /dev/ttACM0 – Chris Stratton Oct 27 '14 at 18:38
  • it is on /dev/ttyACM0 – j0h Oct 27 '14 at 18:53
  • Yes, you need to make use of that information. If you are using the IDE, try the various selection menus. If you are using the command line, edit what you have now into your question and you'll get suggested corrections. – Chris Stratton Oct 27 '14 at 18:54
  • Ive tried variations. Im doing the exact same things that have worked previously. How does someone troubleshoot an arduino uno? – j0h Oct 27 '14 at 19:09
  • 1
    Question has been abandoned without the followup necessary to resolve, voting to close. – Chris Stratton Oct 12 '15 at 5:22

Generated from IDE

Because this is a generic error, I'll answer it. I was getting this on STDERR when using the IDE:

avrdude: usbdev_open(): did not find any USB device "usb"

This is because in the IDE I was using

  • Sketch → Upload Using Programmer [Ctrl + Shift + U]

However, I should have been using

  • Sketch → Upload [Ctrl + U]
  • 1
    Ultimately the comments clarified that this error was produced when trying to burn a bootloader rather than when trying to load a sketch. Burning a bootloader can only be accomplished by means of a programmer. It is unclear what programmer was available to the original poster - specifically if it was one connected via a (virtual) serial port or one connected as a native USB device. – Chris Stratton Oct 12 '15 at 5:20
  • @ChrisStratton new question with answer – Evan Carroll Oct 12 '15 at 8:14
  • 1
    Evan, you deserve a place in heaven for this answer! – user508402 Feb 6 '19 at 19:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.