2

I have a seemingly simple problem but I haven't found a solution yet. I recently got a DHT22 temp/humidity sensor and I wired it according to the guide from Adafruit.

I downloaded and installed the library. I loaded the "DHTtester" example sketch. I also included the Adafruit Unified Sensor library to be safe, because the guide said I might need to. But when I upload the sketch and check the serial monitor the humidity value is always "1.00%". The temperature also seems to be off by about 4 degrees F.

I don't know what is going wrong here. I've removed the 10K resistor but nothing changed. Does anyone know why this might be happening? Any help would be appreciated. Thanks!

enter image description here enter image description here

  • 2
    Without a diagram of your setup, and the code you're using, this is akin to reading tarot cards... – dda Dec 2 '17 at 3:56
  • My setup is exactly the same as the one in the guide that I linked to. I'm using an Arduino Uno. First pin on the DHT22 is connected to 5V, second to 5V with a 10K resistor to digital pin 2, and fourth to GND. – MICROexchange6 Dec 2 '17 at 4:11
  • Then barring a mistake in the code or setup, it might probably a hardware issue -- have you tried your DHT on another board? – dda Dec 2 '17 at 4:20
1

I have 2 suggestions for you.

  1. If you compare these 2 data sheets: This one says "adafruit learning systems" on it and this one is from the Adafruit website , you'll see there is a discrepancy regarding the pull-up resistor value to use. One document says 10k ohm, the other says 1k ohm. It's a bit of a long shot, but you could try adding another 10k ohm resistor in parallel with the one you already have on the data line. This gives you an equivalent resistance of 5k ohm which works when used on a DHT11 sensor (cheaper, less accurate version of the DHT22).

  2. There are several versions of the DHTxx library out there, so my next suggestion is to try a different one. You may have to remove the library you currently have installed before trying a new one.

  • I tried different resistors but humidity is still at 1.00%.The weird thing is that temperature is accurate, which makes me think that the humidity sensor is defective or broken. – MICROexchange6 Dec 5 '17 at 23:24
  • 1
    After a year hanging outside my door in sunny/rainy/windy conditions my DHT22 gave up and shows 1%RH all the time. I don't recommend using it just like that. I have opened it and did some IPA cleaning. It sorted the problem for about a month. If your sensor wasn't stored in good conditions, it may be corroded/contaminated. – smajli Dec 8 '17 at 19:43
0

This problem mainly happens when DHT11 sensor is mistaken with DHT22 or vice versa. Try testing it for DHT11, can you send the picture of sensor and circuit connection if possible.

  • Definitely the DHT22, but I tried uncommenting different sensors anyway, and the readings were wrong. – MICROexchange6 Dec 2 '17 at 20:57
0

When I have rigged up these sensors to test, I breathe on them. Both the temperature and humidity should rise as breath is warm and humid.

From memory, I have seen the humidity rise from ~40% to ~70%, and temperature by at least 5 degrees.

If you see temperature rise but not humidity, then the humidity part may not be working (perhaps as smajli suggests).

There is also a checksum in the data, so I imagine that if there was a problem with communications, the result would be -1 or nothing at at all.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.