2

The arduino-builder app when invoked directly with parameter --tools /usr/bin works, but the IDE fails with the error in the title for any sketch (including the Blink example).

I've tried adding things to preferences.txt like

tools.path=/usr/bin

And variations, but I keep getting the same failure in the IDE. This is using a fresh distro package install on Fedora 27 (I did not have this problem previously using Fedora 25).

  • I'd be interested to hear whether the official version of the Arduino IDE downloaded from arduino.cc/en/Main/Software also has this issue. I've noticed the Arduino IDE version that is in the package managers is always mucked around with so you will encounter strange bugs like this that don't happen with the official version. – per1234 Dec 2 '17 at 10:02
2

I don't understand why this worked, but I found this comment in Redhat Bugzilla (it doesn't seem to be a bug report specifically about that...but anyway):

Parameter 'tools' is mandatory [...]

However, if I create the packages directory in ~/.arduino15, compilation now works.

mkdir ~/.arduino15/packages

Seemed like an easy thing to try, and voila -- after an hour of fuss.

I do not understand why this is so (nothing ends up in that directory, either) but I'm leaving this in hopes it may save someone else some time.

1

The problem occurs because arduino does not have permission to modify directory in /usr/share/arduino to create tools-builder

All you have to do is navigate to usr/share/arduino create 'tool-builder' directory sudo mkdir /usr/share/arduino/tools-builder

  • This is what I needed to do. Fedora 27, arduino IDE 1.8.4 – AWippler Dec 25 '17 at 1:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.