1

My Problem:

ESP8266 wakes up --> takes measurement --> looks for known SSIDs --> uploads data --> goes back to deep sleep

This whole process works with android hotspots and other "normal" wifi routers, but for some reason it does not work with hotspots hosted by iPhones. I tried it with iPhones 5SE, 6 and 7 over some time now so the problem should be constant through many iOS versions.

If another device is already connected to the iPhone's hotspot the upload works--> the interesting thing is, that the iPhone does not list the ESP8266 as connected device even though it is connected because otherwise the upload would not work. I've tried different ESP8266 Version from 1 to 12F and some NodeMCUs.

I did not find anything about this problem yet so I'm asking here if there are any known issues with the ESP8266's hotspot preferences.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.