0

My digital inputs are behaving as if they were floating, even though I've properly connected them with a resistor. I've tried the pull-down configuration pictured below, as well as a internal pull-up.

By using digitalRead() and serial.pintln() I've collected the state of each input tested (0 to 10) and they all do the same: random 0's and 1's. When I change a state (press or release the button), they seem to work for a second or two, then, they go crazy again. Sometimes, they even work backwards (showing HIGH when it's supposed to be LOW) for a couple of seconds.

Is my two-day old Arduino UNO fried?

Arduino UNO diagram

  • I'm voting to close this question as off-topic because it's a defective hardware problem, not applicable to anyone else – user31481 Nov 14 '17 at 8:36
  • Have you confirmed that the signal at the pin-headers are accurate using a known-good test tool, like a multimeter? – jose can u c Nov 15 '17 at 2:31
3

Solved it, but here is the solution, so there is an answer available for anyone who might encounter the same problem...

Quality check your protoboards. This is making me feel stupid. The protoboard I used had a faulty connection on the blue line I was using, causing an inevitable floating input. So relieved I found the problem, and yet so annoyed!

Take care you all.

  • Some solderless breadboards have a split right in the middle of the red and blue lines. These sometimes have an interrupted red/blue line. – Gerben Nov 14 '17 at 19:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.