0

I have an Arduino UNO with a CNC shield. The Arduino is almost certainly a clone.

I installed GRBL with no issue and I have assembled a jig with CD-ROM motors. My first attempt to control this with UGS worked no problem.

I powered down to change the stepping with the jumpers and powered back up and was presented with a very hot smell after a few moments.

I removed the power quickly but now I can no longer program the UNO. It gets recognized in my devices but I can't send any code, even blink.

The jumpers were set like many examples I have seen on the web so I don't think this was the issue.

I am wondering if the way I powered it up was the issue? I am supplying the UNO with 12V 2A supply and I can't recall what order I plugged them in but I get the feeling it must have been supplying 12V to the Arduino.

I have now removed the shield and powering the unit solely from the USB and still can't communicate.

I have resigned to the fact this board is now toasted. Is it important which order you plug in the Arduino? USB first? Do you think it will be possible to recover this Arduino.

  • 2
    A schematic will be really useful (Arduino + Shield + Motors + Power). – user31481 Nov 10 '17 at 10:11
  • so many words, so little information .... all we know is that you plugged the arduino into something unknown, in some unknown way, and something, or other, got burned up. now you are asking if it is repairable? ............... did i sum that up correctly? – jsotola May 3 '18 at 21:29
1

This sounds as the ATmega328p processor of the UNO was fried. As the UNO has a second processor (ATmega16U2) which is simply a USB-to-serial converter you only see the presence of this in the list of USB devices but it cannot communicate with the board's main processor anymore.

The plug-in order is not that important with the UNO board only but depending on the components you have attached it may be important. especially if the circuit does not have protection against induction current, p.e. fly-back diodes.

1

Genuine Arduino's have an input limit of 20v and a recommended voltage of 7-12v. I naively assumed that the same would be for the clone but it has a max input voltage of 9v. Supplying 12v to the unit worked for a short time but the regulator must have melted and cooked the main processor.

1

The same exact thing happened to me. I was using A4988 on a CNC shield which was mounted onto my arduino uno by rexqualis. A couple days ago it was working (inconsistently) to move my NEMA 17 motors. Today, I adjusted the potentiometers on the A4988 to try to improve consistency when my arduino would no longer connect to the serial port. I took the shield off and realized the arduino was very hot. Now it gets hot anytime I plug it even with no inputs or outputs. It will still not connect to the serial port.

I was using 12V of power going into the CNC shield. This and 9v seemed to work a couple days ago. I am not sure of how to avoid this problem in the future, but I am thinking that I need to put the potentiometers where they were before.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.