1

This question already has an answer here:

I'm using a Windows computer, and if I recall correctly I installed the IDE using the installer, so I probably don't need to manually install the drivers. However, I can't figure out how to set up the serial port with the Arduino. For me under Tools, there's no "Serial Port" option but instead "Serial Monitor" and "Serial Plotter."

When I tried to upload my file, it failed. When I clicked Serial Plotter, it gave this error message:

Arduino: 1.8.4 (Windows 8.1), Board: "Arduino/Genuino Uno"

Sketch uses 940 bytes (2%) of program storage space. Maximum is 32256 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for
local variables. Maximum is 2048 bytes.
avrdude: ser_open(): can't open device "\\.\COM1": 
The system cannot find the file specified.

Problem uploading to board.  
See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.
Board at COM1 is not available

This report would have more information with 
"Show verbose output during compilation"
option enabled in File -> Preferences.

How am I supposed to resolve this?

marked as duplicate by user31481, sa_leinad, SDsolar, MatsK, KIIV Nov 27 '17 at 13:30

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    Check the Hardware manager in Control panel that recognizes your arduino board connected. – Juan Botero Oct 28 '17 at 6:10
  • 2
    Is it a genuine Arduino or a cheap clone from eBay or Amazon? – Majenko Oct 28 '17 at 7:32
  • "under Tools, there's no "Serial Port" option". It's Tools > Port. Is that menu item disabled? – per1234 Oct 28 '17 at 11:15
  • Yes, it's the only option under Tools that's grayed out and disabled for me. – Amir Atreides Oct 28 '17 at 23:14
  • I'm not sure if this is related but my computer doesn't seem to see my Arduino although it's plugged in. If I go to the Device Manager it's not even there. – Amir Atreides Oct 28 '17 at 23:22
0

I figured it out by following the tutorial by Adafruit. I had to install it manually in order for it to work.

  • The idea behind answering your own question is that it could be helpful to others who are having the same problem. This answer does not provide enough details to be helpful. Please edit to improve it. What tutorial are you talking about? Add a link to it. But don't only rely on the link for your answer because if the link goes dead the information is lost. Add a description of what you mean by "install it manually". – per1234 Nov 17 '17 at 0:09

Not the answer you're looking for? Browse other questions tagged or ask your own question.