0

I have been trying to bootload a fresh ATmel328P-PU micro-controller with Arduino but it keeps on failing, giving this error:

avrdude: Device signature = 0xff00ff
avrdude: Expected signature for ATMEGA328P is 1E 95 0F
         Double check chip, or use -F to override this check.

The device signature keeps on changing every time I click the Burn Bootloader option.

I referred Arduino Official and Instructables.

Please help. How could I install the Arduino bootloader in a fresh ATmel328P-PU?

I hope someone has solved this already!

  • Sounds like a communication error to me. Check your wiring. – Majenko Oct 16 '17 at 10:58
  • I had tried with 16Mhz external Crystal oscillator and built in 8MHz Oscillator, It is not connection issue – ABI Oct 16 '17 at 11:01
  • 1
    What does the crystal have to do with potential communication and wiring issues? Absolutely nothing. Check and double-check your wiring, then have someone else check it for you as well (i.e., post clear images of it here). – Majenko Oct 16 '17 at 11:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.