0

Trying to program a Wemos D1 mini board OTA for the first time. I can upload to it correctly with USB. I upload the BasicOTA sketch via usb, and I get the correct response on the serial monitor. Now I try to upload another sketch with the OTA functionality in it and there is no OTA port in the ports list to upload to. I have tried everything I know how, restarted, reinstalled everything including the IDE, disabled the firewall. Can someone please help me make this work like it's supposed to?

5
  • I have uninstalled and reinstalled the Esp8266 core, the Arduino IDE, and Python and there is no change, no OTA port shown. I also tried with a Huzzah board I know works, and no OTA port still. – perigalacticon Oct 13 '17 at 5:41
  • ESP8266WebServer is working for both boards. – perigalacticon Oct 13 '17 at 5:58
  • is the ESP in STA mode and on the same WiFi network as your computer? – Juraj Oct 13 '17 at 16:46
  • I found that the problem is resolved if I restart Bonjour service and stop the antivirus firewall, which is a very undesirable action to have to take. – perigalacticon Oct 15 '17 at 13:35
  • I have the same problem, sort of. I have 4 boards, sometimes none show up, mostly one, and sometimes all four. But in "Bonjour Browser", found on hobbyistsoftware.com/bonjourbrowser, I see all 4 ESP8266, in addition to the other services like google home and tradfri gateway. So the arduino UI must be buggy picking up the ESP announcements. It would be nice to be able to enter the addresses of the ESP's instead of waiting for the Bonjour protocol. – Lenne Feb 28 '19 at 23:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.