0

I am kind of a newbie when it comes to stepper motors so I am hoping I am not asking any stupid questions.

I am trying to run a 3-5v micro stepper motor (PM15S-020-SKH4) using a Pololu A4988 stepper driver. I know the driver isn't originally meant for low-voltage stepper motors but I had some lying around and from what I understand it should not be a problem as long as the pot-value is set correctly.

Now I've identified the coils on the stepper motor and connected everything with an 12V power supply, Arduino Uno, 100uF capacitor as described in the Pololu schematic. I couldn't find the current specification for the stepper motor but if my calculations are correct with 5V / 30 Ohm it should be 160 mAmp so per another calculation I've set vRef value for the pot-meter to 0.160 * 0.4 = 0,064

The code I run on the Arduino is;

#define PIN_DIR 1
#define PIN_STEP 3
#define PIN_ENABLE 5

void setup() 
{
    pinMode(PIN_DIR, OUTPUT); 
    pinMode(PIN_STEP, OUTPUT);
    pinMode(PIN_ENABLE, OUTPUT); 

    digitalWrite(PIN_ENABLE,LOW);
}

void loop() 
{
    digitalWrite(PIN_DIR,HIGH); 

    // 20 pulses of 18 degrees should make one full rotation
    for(int i = 0; i < 20; i++) 
    {
        digitalWrite(PIN_STEP,HIGH);
        delayMicroseconds(500);

        digitalWrite(PIN_STEP,LOW);
        delayMicroseconds(500);
    }

    delay(1000);
}

When running the above code, the shaft is harder to move compared to a disconnected motor so there is resistance between the coils what should indicated that they are powered. But when running this the only thing the motor does is make a whirring noise and struggle/tick when I try to rotate it with my fingers.

I have tried multiple of the same type motors and drivers but all yield the same result.

I have a feeling I am overlooking something very obvious but I have no idea what, or am I being a complete idiot trying to combine the Pololu A4988 and the PM15S-020-SKH4?

  • Maybe your current is too low? – Chris Stratton Oct 10 '17 at 22:50
  • I have tried to increase the vRef on the pot-meter in ranges from 0.1 until even 1 (where to motor got really hot) but all with the same result. – Thys Oct 11 '17 at 8:16
  • Any chance you mixed up the pins and are toggle the direction or enable but not the step? Are both coils truly connected? – Chris Stratton Oct 12 '17 at 17:48
  • I have given up on trying to get this to work and switched to a servo. I have hooked up the setup to a NEMA17 stepper motor (with alterations to the current) and it works fine. I have tried the small stepper motor in many, if not all configurations and I just can't get them to work. – Thys Oct 27 '17 at 7:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.