0

On my Linux Mint 17 Quiana I have manually downloaded and ran several versions of the arduino IDE (1.05 which is in the repo, 1.6.x for some time, now 1.8.3). Things worked like a charm.

Now I am trying to get the IDE 1.8.5 going, but I cannot get the IDE started. Started means: I download, extract the files to a directory and run the install.sh command such that the desktop icon gets created. This finishe with a success message. Now I am clicking on the desktop icon, but nothing happens.

Need to say that the IDE 1.05 which comes as a package with Qiana works just fine. I have run the install.sh of both to and fro, but only the 1.05 will start properly. I checked on the desktop link, the execution rights, user, group etc. They are all looking fine for 1.8.5 but it wont start.

I tried to start the 1.85 arduino IDE from the command line - hoping to get some clue from error messages:

java -DAPP_DIR=/opt/arduino-1.8.5/ Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel processing.app.Base

--> running this it tells me, that the main class cannot be found.

Any hints where I am going wrong? Are there any config files to be cleared up, paths to be set ...?

0

You do not need to install Arduino at all. In fact I have never had it work right due to things not being found.

All you need to do is, from a terminal, run the arduino command in the extracted directory:

fred@computer:~/arduino-1.8.5 $ ./arduino

Any errors that then throws will be a clue as to why it doesn't want to work.

  • Hi there thanks for replying. I found the issue based on the idea to call arduino from the command line as proposed by you. Stupid me had downloaded the 64bit version but am still running on a 32bit kernel. I now got the 32 bit IDE and it works like a charm. The problem was so weird - it had to be something stupid :-/ Best Al – A.L.Brecht Oct 10 '17 at 22:28
0

1.05 is the latest available packaged version (and is quite dated).

You can download and (optionally) install the new version. See Installing Arduino IDE on Linux

Either remove (or ignore) the old version. Apart from the additional support the new version supplies, the directories differ - you can either change to the new (recommended) or change the settings.

There is no NEED to "install" the new version. The supplied script DOES NOT install in the traditional sense, it merely installs GUI links to the download.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.