1

I have downloaded and used Arduino IDE v1.8.4 from official site (needs no install) for windows10, and connected my random board with a ch340, but it's LED is only blinking and I can't select the port (ie. it's grayed).

I did test all USB ports and restarted my laptop but that didn't work!

I tried to install 1.6.9 IDE that I had before, but again the port option is unselectable!

This is my board: http://uupload.ir/files/xgv_uno.jpg

7
  • 1
    What OS are you on? Is it a Genuine Arduino board?
    – Majenko
    Sep 21 '17 at 11:23
  • Which LED is blinking? Any chance of a screenshot?
    – sa_leinad
    Sep 21 '17 at 12:19
  • Have you tried a new cable? or a different laptop? If you have is its possible you have the wrong board selected? Sep 21 '17 at 15:59
  • 1
    @sa_leinad: i have edited my question
    – WDR
    Sep 21 '17 at 18:31
  • 1
    @CodeGorilla: Cable is OK, and I have no computer at know to test it
    – WDR
    Sep 21 '17 at 18:32
2

Simplest possible thing would be that you do not have CH340g driver installed and you should try installing it first; These boards use CH340 for usb to serial and they need the driver to be installed; Please give it a try by getting the driver from the following link http://www.wch.cn/download/CH341SER_EXE.html or any other reliable source if there is any problem with the link;

If the board is not recognized even after that, it could be a bad USB port or a bad USB cable or even a board with the CH340 chip dead;

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.