0

I cannot upload my sketch to my arduino DUE.

I get this error:

Send auto-baud
No device found on COM8
Set binary mode
An error occurred while uploading the sketch

The IDE recognizes thought that port 8 is the DUE programming port. Also i get a response when i press "Get Board Info".

After searching online, i found out it has to do with my baud rate. So i use the "mode" command in windows and the baud rate is 115200.

So i use this command:

mode com8:1200,n,8,1

When i retype mode, then indeed, COM8 is at 1200 baud. Then i try to reupload and it fails yet again!

So i retype "mode" and COM8 is back to 115200.

So i think the IDE resets the baud rate to that value.

Any clue on what to do?

  • 1200 baud is only used as a reset trigger when using the native USB port. 115200 baud is correct for uploading. Do you have anything plugged into the board? Did you have anything plugged into the board when it stopped working? Have you tried a manual erase procedure? – Majenko Sep 11 '17 at 21:54
  • My god... Yeah, i had an OLED display. When i removed it it worked!!! I dont know why? This is the pinout i used #define OLED_MOSI 11 //D1 #define OLED_CLK 12 //D0 #define OLED_DC 9 #define OLED_CS 8 #define OLED_RESET 10 Also another pin to 3.3V and another pin to GND. Thanks a lot! – user1584421 Sep 11 '17 at 22:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.