0

I tried to download the ATmega16 board in my Arduino. I have set below URL under File->Preference->Additional board manager URL

https://mcudude.github.io/MightyCore/package_MCUdude_MightyCore_index.json

I am getting below attach images. How can we resolve this error and install atmega16 board manager?

I am using Arduino version 1.6.9. I don't have any issue in opening MightyCare and Arudino URL from my chrome browser.

Error_in_BoardManager

  • Does the download error occur if you test it with a different JSON index from another project? That would tell you whether or not the problem was specific to this package. – ContinuousLoad Sep 10 '17 at 18:49
  • I believe you will get the same error even if you did not have the MightyCore additional URL added to your preferences. This might be caused by network security settings preventing the Arduino IDE from downloading the file. Try whitelisting the Arduino IDE in your firewall software. You can configure proxy settings in the network tab of File > Preferences if necessary. – per1234 Sep 10 '17 at 21:31
  • @ContinuousLoad - Yes. the download error occur irrespective of JSON index or URL. – Simbu Sep 11 '17 at 6:00
  • @per1234 - It seems Arduino IDE is not looking for mightcore URL mentioned under Preference. It is my personal laptop. I am not sure where i have to check for the network security settings. Note- Earlier i have no issue with the old json URL. Issue raised only when I update the mightcore URL. – Simbu Sep 11 '17 at 6:02
  • "Issue raised only when I update the mightcore URL" Have you verified this by removing the MightyCore additional Boards Manager URL from your preferences and opening Boards Manager? Boards Manager always attempts to download the official Arduino Boards package index file first followed by the additional URLs. It has the unfortunate behavior of giving up after the first URL that fails download. So if the Arduino URL fails then it won't even attempt your additional URLs. – per1234 Sep 11 '17 at 6:55
2

Thanks for everyone help here.

I have resolved by few steps.

1) File -> preference -> Board manager URL as like below. Basically URL are seperated by commas. http://arduino.esp8266.com/stable/package_esp8266com_index.json,https://mcudude.github.io/MightyCore/package_MCUdude_MightyCore_index.json

2) Deleted the tmp file (package_index.json.tmp) which is in the path C:\Users\SIMBU\AppData\Local\Arduino15\

This helped me to resolve the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.