1

First of all, I would like to apologize for posting this error once again to this community. However, I have been studying articles for last many days to resolve this error. Unfortunately, I did not get any solution which could resolve my problem.

Below is the error which I get when uploading a sketch (even the example sketch):

warning: espcomm_sync failed
error: espcomm_open failed
error: espcomm_upload_mem failed
error: espcomm_upload_mem failed

Here are the connections:
Vcc - 3.3V
RST - 3.3v
CH_PD - 3.3v
Tx - Rx
Rx - Tx
GPIO0 - GND
GND - GND

I tried various combinations like Tx to Tx, Rx to Rx, pulling off GPIO0. Pulling off reset and ch_pd. Supplying external power source, supplying power directly from Arduino using 3.3V. Supplying power from Arduino 5V using an LD33V regulator. I have even tried uploading the code using USB to TTL. But every time I get exactly the same error.

0

Well, first of all you should make sure that the voltage on both Tx and Rx pins of the ESP8266 is 3.3V (the Tx and Rx voltage on Arduino is 5V). Personally, I've never succeded in using an Arduino to program the ESP (even though there are plenty of examples of this setup in the web). After a while, I just gave up and bought a converter to do the job for me (it's totally worth it).

Even so, I got this error a few times. You must keep two things in mind:

  1. In operation mode, the CH_PD pin must be connected to 3.3V, but it won't do any harm to let it connected during the flashing, so I just soldered a wire between these two pins to make things easier.

  2. In flashing mode, GPIO0 must be connected to GND. It won't work otherwise. I strongly recommend you using a usb converter for this, and only connect it to your computer once GPIO0 has been set to GND. This has solved this issue for me, in fact I even soldered a switch on my converter between GPIO0 and GND.

Hope this answers your question.

EDIT: Here are some photos of the setup

ESP-01 with the wire soldered between CH_PD and VCC

USB to Serial converter for the ESP-01 (and a switch poorly soldered on the back)

  • tried ur ways too. nothing worked :( – Rohit Mathur Sep 5 '17 at 11:23
  • Have you plugged to the device to the USB port AFTER you connected GND and RST? Are you trying to supply power with the arduino, or are you using a converter? If you're using a converter, which one is it? – amorimph Sep 5 '17 at 11:39
  • If you are using the arduino, also keep in mind that you must connect Tx with Tx and Rx with Rx, since you're just using it as an interface between the computer and the ESP8266. – amorimph Sep 5 '17 at 11:53
  • Oh, I just noticed. I said RST and GND, it's actually GPIO0 and GND. Sorry for the mistake. It should work now. I editted the answer so others can see the right setup. – amorimph Sep 5 '17 at 11:56
  • It didn't. I made a check on the voltage too. It was absolutely fine. I tried it to connect to external power supply. but didn't work. still the same error – Rohit Mathur Sep 7 '17 at 18:24
0

Please verify you're choosing the right board -Generic ESP for ESP-01.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.