0

My Arduino Uno R3 is not detected by any laptop (I tried 3 laptops). Under devices there is no Arduino port or other devices option. It does not make sound on inserting USB cable. On plugging the USB LED 13 doesn't blink. I is just continuously on. Reset also didn't blink LED 13. Even on external power also it's not resetting.

I checked the USB cable but it's working for my friend's Arduino in my laptop too.

5V Pin giving voltage around 4.96 v, and 3.3 also giving voltage around 3.27 v.

Now I don't have access to any other Arduino for testing. Is there any way to figure out whether the ATmega chip is fried or whether it's a bootloader problem? And how to fix them? Thanks in advance.

  • Consider swapping socketed Arduino processors to see if the problem follows the processor. Be careful about not bending pins. Also avoid static electricity. – st2000 Sep 3 '17 at 12:34
  • Genuine Arduino or cheap oriental clone? – Majenko Sep 3 '17 at 12:46
  • Please check the answer at arduino.stackexchange.com/questions/44957/… – techniche Sep 22 '17 at 4:36
1

While installing the Arduino software,
there are several window pop ups which occur to install the drivers needed for the operating system to communicate with the device.
Click install to all of them.

0

If you have access to a linux computer, what does lsusb say when it is plugged in over USB? Compare that output to lsusb with no Arduino plugged in. If you don't, does the arduino show up as a device to your OS at all?

You could also use your friend's arduino to reflash your bootloader. If that still doesn't work, or if your arduino doesn't show up as a device, you can try reflashing the atmega16u4 ( the USB <-> serial chip ). It is the chip responsible for telling the computer that it is an arduino serial port, so if things are still getting power, but not showing up, I would check that chip.

If it is neither of those things, there may be something wrong with one of the passive USB components, maybe one of the varistors died and is now shorted to ground, for instance. I could give more help if you share the schematic for your specific board.. is it an official Arduino, or a clone?

0

Can't upload the program to Arduino Uno

if your trouble is limited to just "the program", then the issues must be specific to that program.

if you cannot upload "any program", then the issues must be hardware or host related.

0

It is probably not a problem with the Atmega328p chip or its bootloader; the Uno has a separate processor to handle USB - an Atmega 32U4, which is the flat, surface-mount chip right behind the USB connector on the board. If that or its firmware is damaged, your PC won't recognize the device when you plug it in. If that chip is up and running, your PC will see it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.