1

I've recently bought a SIM900A A6 GSM module. Whenever I send a command it gives an error: +CME error 58.

Does anybody know what this means and how to solve it?

  • Post your schematic and a complete test sketch that show your problem. – user31481 Sep 1 '17 at 16:44
  • I am also working on A6 and receiving the same error. I suspect it has something to do with the power supply. Will post my final answer once I have finished. Hassan (hassan.uh@gmail.com) – Muhammad Hassan ul Haq Oct 6 '17 at 6:40
  • Which commands are you sending? From my experience it seems the command isn't supported. What happens if you issue just AT or ATZ? – Petr Pudlák Oct 28 '17 at 14:26
1

Your sim card is probably protected by a PIN. Easiest way to get it working is to put the SIM into a normal phone and remove the PIN protection.

  • I've already done that it is receiving text messages and calls but its still giving this error – luukito Sep 1 '17 at 20:56
0

I had the same error. My error was using the incorrect baud rate. Set the baud rate to 115200. Also, ensure that "Both NL & CR" option is selected for new line options. After changing those settings, I had to reboot the A7, and wait for all the status messages to complete before I could send the AT command.

protected by Community Jan 30 '18 at 6:48

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.