1

I'm trying to get my Arduino GSM shield working with the example "Send SMS" code provided. However, when I upload and compile the program, the serial monitor displays "SMS Messages Sender" and nothing else occurs.

Would greatly appreciate it if someone can tell me where I could have gone wrong.

EDIT : I'm currently using the Arduino Mega. The shield I'm using is the Arduino GSM Shield. I'm following the guide provided by the Arduino's website with the code part of the example that comes with the Arduino program, see Sending a SMS message. Attached is what is shown on the monitor.

I am using both a USB cable and an external power supply. I have performed the jumper wire modification required for the Mega to work with the shield as well.

Console output

  • 1
    Could you provide some more information please? It might be useful to have details of exactly which Arduino board and shield you're using, and what code you're trying to run. – Peter Bloomfield Oct 3 '14 at 9:00
  • Please, also add the code you have uploaded to your MEGA, rather than just saying "the code provided"; try to ease the job of people who want to help you, thus give a chance to your question of being answered! – jfpoilpret Oct 5 '14 at 6:04
1

This is an old post, but for future people:

The shield may have not been switched on — it has its own power button, which is right next to the SIM card. It's tiny, but it's there.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.