I have been given a board(Atmel ATmega328P-AU 1640) to program. I googled and found category of board Arduino Uno/ CH34x-based clone.

But when I program an empty program:

void setup() {
  // put your setup code here, to run once:


void loop() {
  // put your main code here, to run repeatedly:


I get this error:

Sketch uses 444 bytes (1%) of program storage space. Maximum is 32256 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00

These are all the ports that are available to me. I have connected my Arduino with one of the USB ports on my Macbook running MacOS Sierra

enter image description here

enter image description here

enter image description here

  • Why do u thing that is an arduino
    – PeterJ
    Aug 19 '17 at 18:21
  • Because I was told @PeterJ I might be wrong Aug 19 '17 at 18:23
  • Why do you want to connect it via Bluetooth?
    – PeterJ
    Aug 19 '17 at 18:25
  • that's the only port available. Hey, I see this is Atmel's board....Do I need Atmel Software to code it? I'm not an electronics guy. Please fix(edit) this question if wrong Aug 19 '17 at 18:26
  • Can we see a picture of the board?
    – uhours
    Aug 19 '17 at 18:27

You have an Arduino nano clone using a CH340G chip for serial communication. You to down load and install a driver for your computer to recognize it. I don't use OSX, so there's not one I can recommend.

  • tell me for Windows Aug 19 '17 at 18:58
  • I also have windows installed in Bootcamp Aug 19 '17 at 18:58
  • I have installed both CH340G & CH341G but still, no other USB ports are showing except Bluetooth one Aug 19 '17 at 18:59
  • 1
    Sorry, I use Linux, and have the driver built in. If it's still not showing up, you either did it wrong, or the device is damaged.
    – uhours
    Aug 19 '17 at 19:31

That looks like a clone of an Arduino Nano to me, with a CH340G chip as the USB interface chip. You need to:

  1. Install the CH340G drivers
  2. Ensure that the ATMega328PU chip has a bootloader installed on it

The last Nano I bought from China didn't have a bootloader installed. There are many tutorials online for teaching you how to install the bootloader using another Arduino as the programmer.

  • can you post some links how to fix bootloader on MacOS? Also I have already installed CH340G. I saw a youtube video but it's still no showing me other ports. Please confirm what board category should I select thanks :) Aug 19 '17 at 18:47
  • how to check if bootloader installed on it or not....please provide me with some direction. I've no experience with electronics & Arduino stuff @Majenko Aug 19 '17 at 19:21
  • 1
    The led L should blink rapidly a few times when you press the reset button.
    – Majenko
    Aug 19 '17 at 19:26

The board is an Arduino Nano clone, not an Uno.

  1. Plug the Nano's USB cable into your computer.
  2. Download and install the CH340 driver from here: http://www.wch.cn/download/CH341SER_MAC_ZIP.html
  3. In the Arduino IDE, select the port of your Nano from the Tools > Port menu.
  4. Tools > Board > Arduino Nano
  5. Sketch > Upload

If the port of your Nano doesn't appear in the Tools > Port menu (and no, dev/cu.Bluetooth-Incoming-Port is not the correct port) then you may have a damaged or charge-only USB cable. Try using a known-good cable or verify that your cable works for data on another device. If you have it plugged into a USB 3.0 port on your computer then try a USB 2.0 port instead.

  • Yes usb 3.0 doesn't work I'll try with 2.0 Aug 20 '17 at 5:09

Try this instructions from install driver. https://github.com/adrianmihalko/ch340g-ch34g-ch34x-mac-os-x-driver

Installation with Homebrew-Cask.

Then try this, and all work fine ;) http://www.instructables.com/id/How-to-fix-bad-Chinese-Arduino-clones/

  • Please don't post URL answers, write the gist of it and refer to the URL.
    – MatsK
    Jun 18 '18 at 11:10

Remove the old driver by issuing one of the following commands (depending on your installation):

  • sudo rm -rf /System/Library/Extensions/usb.kext
  • sudo rm -rf /Library/Extensions/usbserial.kext

Restart your Mac.

Install with Homebrew-Cask Install the driver by the following commands

Restart your Mac.

Try upload some code in your Arduino. In some cases the board might still not work.

This is because there is no bootloader installed on the Atmel microcontroller ship. To solve this problem we need a working Arduino and the clone Arduino we want to fix.

![Make an ISP Programmer From Your Working Arduino ]1

First we connect the working Arduino to our computer and open the Arduino IDE.

We go to File -> Examples and click ArduinoISP and upload this to the Arduino. Ones uploaded disconnect the Arduino.


Connecting the Wires


Connecting the Wires

Next we connect the wires from the working Arduino to the clone as follows.

Without 10 uF capacitor.

Go to Tools -> Board and select the chinese board that is not working. in my case it's an Arduino Genius/Uno

Next we go to Tools again -> Programmer and select Arduino as ISP.

Go to Tools again and select "Burn Bootloader".

Go back to Tools -> Programmer and set back to ArduinoISP.

Your clone should work just fine now. ;)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.