1

I just recently installed the ESP8266 libraries on the arduino IDE using the boards manager, the code compiles fine with the ESP, but when the board is changed to UNO, i get this error,

opt/arduino-1.6.7/hardware/tools/avr/bin/avrdude: error while loading shared libraries: libreadline.so.6: cannot open shared object file: No such file or directory

Any solution to this?

  • You have to keep your software updated. Arduino IDE is currently in version 1.8.3. – user31481 Aug 3 '17 at 14:01
1

So install it?

$ sudo apt-get install libreadline6

Or, if you need the i386 version on an x64 platform:

$ sudo apt-get install libreadline6:i386

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.