-1

I'm getting error while uploading sketch into nodemcu ch340g as shown below enter image description here

I have tried these things to rectify the error
1) Changed usb cable
2) changed the port
3) flashed the firmware with nodemcu_float_0.9.6-dev_20150704.bin by esptool.py
4) flashed with nodemcu flasher
But no change at all and it is showing same error only what can i do now

  • I had a similar problem yesterday, I had plugged a shield into my D1 the wrong way around. Is it possible you have made some incorrect connections? – Code Gorilla Aug 2 '17 at 12:09
  • I have disconnected all the things ,even though it is showing same error – rahul bommaraju Aug 2 '17 at 12:23
0

3) flashed the firmware with nodemcu_float_0.9.6-dev_20150704.bin by esptool.py

So assuming that actually completed successfully you can rule out anything being wrong with your hardware. There is no difference between manually flashing a firmware file and flashing using the IDE.

You need to take a look at the command you used to flash that firmware successfully, especially things like which port you used and what baud rate, and make sure you replicate those same settings in the IDE. Especially the baud rate, which you can select in the Tools menu.

-1

Problem solved by doing this In boards, I have mentioned node MCU 1.0 and that's the mistake I have done, after changing the board to node MCU 0.9, then the program is uploading and thanks for all your suggestions

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.