1

I just picked up a new Arduino Micro for a project, but the first time I tried to upload to it, things went terribly wrong. The USB cable was loose, so the power light kept blinking on and off. When I did get it stable, I accidentally had 'Uno' selected under 'Tools->Board'. I think this was the source of the problem.

I'm aware that the solution for these kinds of problems is to try to upload some simple code while in bootloader mode, but pressing reset shortly after pressing the Upload button. But this board doesn't even respond when I press reset. I have tried it with both the on-board button and with an externally button linking RS to ground.

Furthermore, the board doesn't show up in my Device Manager, not even as an "Unknown Device". The device managed doesn't even refresh when I plug it in.

I know the connection is okay because the power light is on. And I know it's not a driver issue or an issue with the port, because I have no trouble getting a different Micro recognized.

The only thing I haven't tried is burning the bootloader through ICSP, since I don't have the right cable. Is there anything else I can try, or is this just bricked?

Thanks, everyone

  • That appears to be based on a 32u4, so if it isn't physically damaged you may be able to recover it using DFU mode - at least it's worth doing some research on the subject. – Chris Stratton Sep 24 '14 at 15:01
  • This certainly seems plausible, but it looks liek getting into DFU mode requires resetting the board via the ICSP headers. I have tried that, and just like when I reset with the pushbutton or by connecting the RS pin to ground, the board doesn't respond in any way. Or do you think I'll regain the ability to reset later on in the process? – steve.mcgie Sep 24 '14 at 20:41
  • You can use another arduino as ICSP programmer. – Gerben Sep 24 '14 at 21:00
1

This is probably way to late, but with newer editions of the Micro you have to "double-press" the reset (input).

I have had some experiences today where playing with low-power modes that shuts down the usb interface, and the only way I got it back was activating the reset input twice fast, and then uploading a new scetch (this time with a 10sec delay before any usb-chaning stuff takes place!)

Richard

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.