0

I'm trying to follow this tutorial. But I'm stuck in this error:

Can't find OV2640 module! pid: 254

I tried to contact the author of the program, but I have not had an answer yet. I'm using the ArduCAM Mini module OV2640.

Has anyone ever been in this situation?

1

If you look at line 762 of 'ArduCam_ESP8266_FileCapture.ino' you should see it is looking to read two bytes from the camera to check that the model number is either a '2641' or '2642'.

You are seeing the error because you are not getting those values back. So between 761 and 762 insert some debug and print what you are getting back:

Serial.print ("vid = ");
Serial.println (vid);
Serial.print ("pid = ");
Serial.println (pid);

I guess you will either get 00 00 or a different valid (maybe) model number. If you think its a valid model number add another condition to the if statement and see if it works.

Oh and don't forget to post the results, because I'm going to give it a chance too when I get time :)

1

Does it still happen if you power the cameras off and then on again. I was getting the same thing as there is a bug in one of the examples where the cameras are placed into deep sleep mode so when you reset the microcontroller or whatever you have the cameras can't be found because they are sleeping. I add the line

yourcam.clear_bit(ARDUCHIP_GPIO, GPIO_PWDN_MASK);

to clear this state when intialising.

0

Thank you very much for your attention. But the problem was in the dupont connection wires, as mentioned here!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.