I just cannot connect or send AT command from my UNO to A7 AI Thinker module. This is the connection:

UNO    ->    A7
TX     ->    RX
RX     ->    TX
USB    ||    5V    -> External Power Supply
GND    ->    GND

Without any sketch, I tried to send AT command from serial monitor, and nothing happened.

Different case if I use USB TTL to A7

USB TTL   ->   A7
VCC (5v)  ->   5V
GND       ->   GND
TX        ->   RX
RX        ->   TX

Then it is OK, I can send all AT command, SMS, Call, etc from the serial monitor.

Just what is happening with UNO? Does my UNO RX TX Faulty? How to check it?

  • What pins on the Arduino are you calling TX and RX? The normal ones are already in use for the USB-serial, so if you try to use those for something else at the same time, at least one of the two links will fail and you won't be able to tell what is going on. The Uno is poorly suited to use with serial interfaced add-ons, you typically have to use a bitbanged "software serial". Jul 21 '17 at 3:55
  • The pins are 0 and 1 on Arduino. I do not try to use sketch, I just want to make sure that the A7 got the AT commands. If I use SoftwareSerial and connect the tx rx on pin 2 and 3, I should upload the sketch first right? Jul 21 '17 at 6:50
  • I think I am a I'll so facing similar issues with you. I tried sending AT commands to my board and nothing is coming up Could it be that I have done something wrong?
    – OOPeter
    Nov 19 '19 at 7:10

Without any sketch, I tried to send AT command from serial monitor, and nothing happened.

The problem is with your connections to the Uno. Although it seems wrong, the correct connection when you're using the Uno as a USB-serial adapter to communicate with the A7 AI Thinker module from Serial Monitor is:

Uno                A7
TX (pin 1)   ->    TX
RX (pin 0)   ->    RX

The RX and TX markings on the Uno refer to the pins on the ATmega328P microcontroller. But you're not using that microcontroller, you're communicating between the USB-serial chip on the Uno and the A7. The RX line of the USB-serial chip is connected to the TX pin of the ATmega328P and thus to pin 1, the TX pin of the USB-serial chip is connected to the RX pin of the ATmega328P and thus to pin 0. For this reason the connection between the Uno and A7 shown above are actually an RX-TX, TX-RX connection between the USB-serial chip and the A7.

If you were communicating between the ATmega328P on your Uno and the A7 then the connections you used would have been correct.

  • This is make sense. I tried to connect TX->TX and RX->RX but this error came out: Invalid or no response from the device. Please check the modem port and the baud rate.Disconnecting port COM3.. I set the baud rate to 115200. What is happening here? Jul 28 '17 at 3:21
  • Are you communicating with your computer over Serial e.g. Serial Monitor) and also communicating with the A7 module over Serial at the same time? That is problematic. It may be better to communicate with the module via software serial and leave Serial to be used only for uploading and communicating with the computer. Keep in mind that software serial doesn't work reliably at 115200 baud.
    – per1234
    Jul 30 '17 at 1:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.