4

So recently my company threw away some rather large and reasonably old laser printers. One was a LaserJet 9050dn the other was a Epson printer/scanner combination. Being a little industrial I thought let me salvage them and brought them home.

I managed to salvage a couple of stepper motors. However I am having huge trouble is getting them to step properly. So lets get into the details.

Components used:

  • 1x Freetronics eleven (Arduino Uno compatbile)
  • 1X H-Bridge driver shield(Freetronics rated for 40V/2A max).
  • 1X Old scanner power supply which has a output of 24V/2A.

Currently there are two stepper motors I am interested in using. They have the following part numbers:

  • 1X MITSUMI M42SP-4N
  • 1X Minebea-Matshushita 17PM-J212-G2ST

Just to keep this short I am going to focus on the Minebea-Matshushita 17PM-J212-G2ST. I have been unable to find exact matches on these serial numbers when looking for datasheets but I have managed to find the following sheets on the net.

  1. Minebea-Matshushita 17PM-K datasheets found from Minebea. However I cant match the model exactly.
  2. Minebea Stepper Motor Information & Specifications also carries some useful information.

So it appears that these are 24V steppers(in both cases). The Minebea-Matshushita 17PM-J212-G2ST appears to have a step angle of 1.8 degrees which should give me 200 steps per revolution. I have not been able to find the current needed to drive this motor but judging by the looks of things it will be between 0.8A and 1.2A.

I then used my multimeter to find the pairs of wires. It has 4 wires coming out (Bipolar motor I guess). The colours of the wires are red, yellow,orange and blue. First pair was red and yellow with red being positive/anode. Second pair orange blue with orange positive/anode side.

I wired my power supply into my h-bridge and started using the recipe and quickstart found at the freetonics site. This is where the frustration begins. When asking the motor to do one complete revolution(360 degrees) it does more than 360 degrees at times and other times it does less. I tied a cable tie to the motor so I can confirm it.

So I tried the one-step-at a time sketch to see if I can troubleshoot it. Here is what I have noticed. The steps are mostly correct one step at a time clockwise however every now and again it will jump counter clock wise and then clock wise again. I suppose you can call it a jitter.

Interestingly both these motor show the same behaviour pretty good step action just every 25 degrees or so a jitter. So I suspect that this might not be bi-polar motors but uni-polar? This blog entry points me to believe that this might be the case. However the datasheet in this case points to a M42SP-7.

So my question would be simple how do I figure out if they are bi-polar or uni-polar?

Can someone help me with a proper datasheet?

Any tips would be really appreciated.

Update:

Note that I can get both motors to step clock-wise and counter clock-wise I just cant get them to do a whole 360 degrees without a jitter. Based on the Wiring Mitsumi stepper ( M42sp-4np) with arduino blog it appears that the Mitsumi is a uni-polar motor with a 2-2 phase excitation. What stumps me is that the wires are paired thus it must be bi-polar?

So last night I tried 2-2 phase excitation with the MITSUMI M42SP-4N and it appears to be solve the problem with this motor in particular. From early observations the motor now steps without jitter, however it was late so I will need to confirm this.

I was previously using 1-1 phase excitation i.e.

Step number: 1a 1b 2a 2b
1            1  0  0  0  
2            0  0  1  0  
3            0  1  0  0  
4            0  0  0  1 
5            1  0  0  0

When using 2-2 phase excitation I get a more steady step however this needs to be confirmed a bit more:

Step number   1a 1b 2a 2b
1             1  0  0  1
2             1  0  1  0
3             0  1  1  0
4             0  1  0  1
5             1  0  0  1

Just some added observations. The headache continues but I am learning a LOT about steppers motors.

Update:

Not a 2-2 phase excitation these are definitely bi-polar. I am currently watching the Minebea-Matshushita 17PM-J212-G2ST do 360 degrees both clock and counter-clockwise. I hooked them up to a 12V/1A power supply both motors are running smoother and cooler and stepping relatively jitter free. I suspect the whole issue is a lack of a proper data-sheet.

Will update as things progress and once solved add pictures and sketches so the next lucky sod wont loose as much hair as me.

Update:

Thanks to Chris who made me look at the sketch in detail again. These motors seem to have a minimum rpm of sorts. I was trying to go for a really slow rpm under 5rpm at this speed these motors show the jitter effect. However when moving the speed to 10rpm and up no jitter.

  • If it's a unipolar, you wouldn't get more than 2 steps out of them. Also, I don't think any unipolar exists with only 4 wires. Try lowering or raising the current limit. – Gerben Sep 8 '14 at 12:35
  • As an experiment, try making the step speed such that it takes a number of seconds to complete a revolution. If that is really a 24v motor, it's probably going to be disappointing in performance (usually one uses a motor having a coil rated for a few volts, with a chopping current drive with many times that in available supply voltage). While it's really AC impedance (inductance) that you need to worry about for performance, what do you measure as the DC resistance of a coil? – Chris Stratton Sep 8 '14 at 19:18
  • @ChrisStratton I suspect that these motors might be using 2-2 Phase Excitation for stepping the recipe I am using appears to be 2-1 Phase Excitation. I have tried driving these with both 12V/1A power and 24V/2A power and getting same results. I am going to experiment a little more tonight but I suspect that the cause might be the phase excitation. – Namphibian Sep 8 '14 at 21:28
  • That seems unlikely to be the issue - at least when unloaded mechanically you should be able to get movement either way. Don't rule out your program glitching especially if there are any bad interactions between motor and logic supplies. Consider having the arduino log to the serial a continuous count of the pulses emitted, and make sure it increases consistently. And try running it slow enough that you can see each step. – Chris Stratton Sep 8 '14 at 21:31
  • @ChrisStratton thanks. I can confirm that this is the case I have made it step one step at a time and monitor the serial log. I used the one_step_At_a_Time example sketch. All seems well. Smooth increments of counter nothing. Also added an update on the 2-2 phase excitation. – Namphibian Sep 8 '14 at 21:53
2

Keeping this here for future reference. It appears these motors have a minimum RPM of sorts and running them on a lower RPM causes the jitter effect described above.

Like I mentioned in the updates when running at 10RPM or above these motors seem to perform very nicely.

Update: I recently bought a ADAFruit motorshield and I am getting much more stable results with this shield and the stepper motors. I am even running them off 6V and they are working perfectly even at lower rpm.

  • 1
    This is a rather mistaken conclusion. There is no "minimum RPM" to a stepper motor. However, there can be speed ranges where various resonances cause problems. – Chris Stratton Apr 11 '16 at 19:59
  • @ChrisStratton thanks for putting that so clear. I suspect now in retrospect that the different shields have different driver ic's which indicates the problem is probably with the shields and not the motors. Its been two years since I worked with shields as I started making my own. – Namphibian Apr 11 '16 at 21:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.