3

I built a custom arduino based board (speciffically based off of Sparkfun's Pro Micro 3.3V 8Mhz and their Qduino mini boards) that uses the ATMega32u4-RC.

The board I built integrated an acceleromter (LSM6DS3) and a micro-SD card holder, and eleminated any uneeded GPIO. (This is basically a datalogger board for the LSM6DS3 accelerometer). It also inlcudes a usb-powered LIPO charging circuit, which is copied from the qduino mini.

A picture of the board I built, with power LED indicating life. My Board

The problem I am experiencing is that, after apparently sucessfull upload of the bootloader (I've tried the bootloader for the qduino mini, promicro 3.3v 8Mhz, even the Leonardo), my computer will not reconize the board. I've exauhsted all the information about driver installation from the sources for the boards my board is based on, and still can't make windows recognize my custom board.

Specifically, I've tried using a multitude of signed and unsigned drivers (on Windows 10 and 7), and can not get windows to pick anything other than usbfilt.sys as the driver.

Any advice would be greatly appreciated!

Edit: Added Eagle Schematic below

enter image description here

  • First thing you should check is if Windows sees a USB VID/PID for this device, and if so if they are as expected. If not, instead of loading the bootloader with ISP load a simple program that flashes and LED or something and make sure the chip runs, then re-check all of your USB wiring. – Chris Stratton Jul 4 '17 at 22:35
  • I uploaded a blink sketch via my ISP (sparkfun's avr pocket programmer) and it worked just fine. The device instance path under properties shows the following: USB\VID_0000&PID_0002\5&173CBDFC&0&1 I'm fairly certain thes are not what it should be showing. Also, USB wiring should work. It's the same as the pro-micro and qduino mini and it's on a PCB, so...I'm not sure what else to check as far as that goes. – user29032 Jul 4 '17 at 22:53
  • Glad to hear the ATmega runs. The VID/PID are obviously wrong, so if you're sure you loaded a suitable bootloader it's probably time to include the schematic in your post and carefully check all the soldering. – Chris Stratton Jul 5 '17 at 0:20
  • 2
    Don't know that it is definitively causative of your problem, but seems like you may have forgotten the 1uF capacitor between UCap and Ground. – Chris Stratton Jul 5 '17 at 1:15
  • That was it! Apparently UCap is needed for the 3.3V board to talk with 5-volt USB system. Thanks A TON! That really saved my sanity there! – user29032 Jul 5 '17 at 2:25
1

As Chris Stratton pointed out, I neglected to include the 1uF capacitor on UCap. This is absolutely necessary on a 3.3v board for the board to communicate with USB properly.

Thanks!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.