2

I have a pro micro and I'm running the IDE on linux. The IDE easily recognises that my board is on /dev/ttyACM0 so i can flash programs on to it. I am testing the following code

void setup()
{
  Serial.begin(9600);     // opens serial port, sets data rate to 9600 bps
}

void loop()
{
  Serial.print("Hello universe ");  
}

After I upload the code if I try to bring up the serial monitor I get this error message

Error opening serial port '/dev/ttyACM0'. (Port busy)

tried resetting the pro micro, rebooting the computer, tried the code

sudo usermod -a -G dialout yourUserName as suggested here

But the problem still didn't solve. Any idea what went wrong.

Edit1:

I noticed that when the arduino is in the bootloader mode (i.e when I press reset) lsusb shows

Bus 004 Device 055: ID 2341:0037 Arduino SA

however, when it starts to execute the program from its memory, lsusb doesn't show that entry. but instead, shows

Bus 004 Device 054: ID 1b4f:9206

  • Modem manager. Every time. – Majenko Jul 4 '17 at 13:03
  • I tried changing the USB cable. IT doesn't seem to be the cause . also check out the edit1. – Ashwin Kumar k Jul 4 '17 at 16:11
  • 1
    To expand on Majenko's comment, try sudo apt-get purge modemmanager. – Edgar Bonet Jul 4 '17 at 17:00
  • Thankyou Edgar Bonet your solution worked. Will you please write it as a solution, also please explain why modemmanager gave the problem. wouldnt uninstalling modemmanager trouble other apps that use it? – Ashwin Kumar k Jul 5 '17 at 10:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.