0

I have a V2 Adafruit Gemma from the Gemma starter pack, and I'm running Windows 10 Home (version 10.0.14393), on a 64-bit laptop. Following the Introducing Gemma guide I've installed the Adafruit drivers and I'm now trying to get it to connect via USB.

After connecting, the board shows the green power LED, but not the pulsing red LED, and Windows shows the 'USB device not recognised' message.

Tried so far

  • I'm definitely using USB 2 ports, and I have tried it connected directly to the PC and via a USB hub.
  • I'm pretty sure the cable is working correctly (It works for exchanging data on a phone, and I've tried a few different ones).
  • Under Device Manager, the board shows as 'USB Device (Device Descriptor Request Failed)'.
  • 'Update driver software' > 'Search automatically...' reports that 'The best driver software for your device is already installed'.
  • If I do 'Update driver software' > 'Browse my computer...' and point it to the manual Adafruit driver files (available on the link to the guide), I get the same message.

Can anyone suggest anything to try? Do I need to (re)install the bootloader itself, and if so, can you point me in the direction of how I do this?

Update

As mentioned in the comments I have posted on Adafruit's own support forum but got absolutely nothing yet. I have also tried it on my work PC (Windows 10 Pro, 64-bit) and got exactly the same behaviour.

I'm keen to get this sorted so bounty added for anyone who can at least come up with some suggestions of what to try!

2
  • "USB Device (Device Descriptor Request Failed)" tends to indicate that the speed select resistor has been seen, but actual USB signalling failed. This could be any number of problems. The Gemma doesn't use a legitimate USB interface, but a rough approximation in software running on the ATtiny. So it could be a compatibility issue, a lack of appropriate software loaded, or a bad board. Given you've already tried with and without a hub, you should probably pursue this with Adafruit on their own support forums. – Chris Stratton Jul 2 '17 at 20:39
  • Yes I've posted on the Adafruit forums too and I've tried with and without the hub as above. I appreciate the message is vague but that's exactly my problem, I'm not sure where to go from there. – Parrybird Jul 2 '17 at 20:43
1

I think, you've pretty much done everything. If you could gain access to another board, and try that one you could figure out more. Otherwise your symptoms remind me of a something called an ESD (Electrostatic Discharge) caused malfunction. This basically means one of the system essential chips on the board have been fried. It is very easy to ESD a chip without protection, just walk on a carpet or put on a sweater, and than touch the chip. Chances are you were electrostaticly charged with thousands of volts. The chip does not stand a chance. To prevent this from happening, touch something made out of metal before touching the board.
More on ESD: Electrostatic discharge

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.