0

I have an Arduino micro for some time and everything always worked well. Today, when I was uploading a code on this board using Arduino IDE, I accidentally started the Arduino Board update and the upload failed. After a while I retried again and again and again but upload always failed. Now my PC doesn't recognize my board and, looking at Windows Device Manager, when I connect my board, appears this screen:

Unknown USB device

What should I do? Do I have to reflash bootloader?

  • 1
    You have a bad sketch installed. Press reset just before upload starts. – Majenko Jun 28 '17 at 12:10
  • to expand on that, whats worked for me in the past is press and hold the reset button while the sketch compiles, and only release the reset button once the IDE is trying to upload. that way it should never get out of the bootloader, so should immediately upload the new sketch – James Kent Jun 28 '17 at 15:21
  • I tried again and again resetting it before uploading, after uploading, during uploading, twice, keeping resetted,... but always the IDE says that the board is not connected. Every time I reset, the led blinks once but nothing happens. What should I do? @Majenko – Leonardo Jun 28 '17 at 20:24
  • You may want to reinstall the bootloader - not to repair the bootloader, but to erase the sketch. A major drawback of the bootloader is that it has no proper manual way of forcing it to run. – Majenko Jun 28 '17 at 20:25
  • Ok and what should I do? Thank you for your time! – Leonardo Jun 29 '17 at 7:13
0

So I was facing this issue for the past few hours and this is how I managed to get it to work. After reading similar issues on knockoff NANOS, I downloaded and installed this as many knockoff NANOS uses a different Serial CHIPSET.

After that, on the IDE side, just press compile to ensure your code is good to go. And then when you hit upload, wait for it to finish compiling and the second it says UPLOADING, hit the reset button. It should upload now and be available in your COM port.

0

I had this issue a while back and in order to fix it as suggested above I had to re flash the boot loader using a 2nd Arduino as an ISP. I used this page as a guide:

https://schou.dk/linux/arduino/isp/

Before connecting the wiring I first updated the UNO with the "ArduinoISP" Sketch, connected the wiring, then flashed the boot loader.

  • Opps, just realised this was asked 1 year, 9 months ago... oh well hopefully someone finds it helpful – user54057 Mar 29 at 4:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.