I am trying to upload a basic sketch to my unofficial Nano-like board and keep getting this error. I understand that it is a generic connection error between the Arduino and my PC, but can't figure out why it is having this problem.

I've looked up the drivers from the manufacturer's website and installed them, and the Arduino Nano shows up just fine under my Device Manager. The green power light comes on, it is recognized by my PC, and blue flashing 'L' light blinks, making me think that the manufacturer had uploaded the Blink sketch to test it. However, when I try to upload a sketch from the IDE I get this error:

avrdude: stk500_recv(): programmer is not responding

Under 'Tools" I have the board set to 'Arduino Nano', the processor set to 'ATmega168' and the port the same COM port as what it's listed as in Device Manager. Assuming that all of those are correct, I have tried a few things with no luck:

  • Reinstalling the IDE, drivers and restarting my computer.
  • Letting Windows find its own driver.
  • Pressing the 'reset' button just before hitting 'upload' in the IDE
  • Using different micro USB cables and USB ports on my computer.

Any other ideas or is the unit possibly just faulty?

Please note that I have already at similar questions and tried a bunch of their suggestions with no luck.

  • Isn't the device ATMega328?
    – user33153
    Jun 18 '17 at 16:46
  • @user43648 The chip on the board says ATmega168PA, but I have tried both with no luck.
    – ThoseKind
    Jun 18 '17 at 19:07
  • 3
    Maybe you have to burn the Arduino Bootloader to it? You would another Arduino (Uno, Nano, whatevere) or a ICSP (in curcuit serial programmer) to do this. Jun 18 '17 at 20:15
  • This is a generic message, yes, so there are several possibilities. 1) that port was somehow busy with another program 2) bad cable 3) bad board, or maybe the PC is confused and a reboot will straighten it out. Presuming you have rebooted then maybe try switching boards and/or cables..
    – SDsolar
    Jun 18 '17 at 22:14
  • The Arduino.cc developers changed the bootloader on official Arduino Nanos to communicate at a different speed. Try setting Tools → Processor → ATmega328P (Old Bootloader)
    – scruss
    Mar 18 '19 at 12:27

That is a Chinese NANO clone, using the notorious CH340G chip.

macOS does NOT have a driver, and it is difficult, if not impossible to get a driver which 1. macOS will let you install, and 2. Actually works.

I do not know the state with current Windows.

In my experience, in addition to poor support the chips are unreliable and fail to respond.

You could try using a Uno as ICSP, bypassing the boot loader, or (untried) use an external USB serial interface. Both of these approaches are documented on the Arduino site.

  • 1
    The official website offers a mac version: wch.cn/download/CH341SER_MAC_ZIP.html Is that not good enough ? In Windows and linux the CH340G is very reliable.
    – Jot
    Jul 8 '17 at 20:30
  • There was a problem with the official CH340 driver not being compatible with macOS Sierra but I see there was a new official release since that time so hopefully it's fixed. You can also find a fixed unofficial version with a few minutes of searching: CH340 has always worked great for me on Windows. The only problems people have is that the driver isn't included with the Arduino IDE but it only takes a minute to download and install the driver.
    – per1234
    Jul 8 '17 at 23:03

For issues like this, you have to narrow down the problems first. For example

is the computer plus programmer combo able to program any avr? If so, the issue us with your target, including wiring.

If not, can the programmer able to program any chip? If so, the issue is with your pc plus programming software.


Going backwards and with solid logic, which means making zero assumption, you will narrow the issues down further.


It's a wiring problem (soldering), check by multimeter (continuity mode). between RST and GND. Then between ICSP pins. you have to get (1) that mean no shorts between the PINS. Good luck!

  • 1
    No, it's not. Your post shows a complete disregard for the actual contents of the question. ICSP is not involved here. Please read more carefully next time! Jul 8 '17 at 19:02
  • 1
    @Ziad please provide more content to your answers to make them more useful for others with the same problems.
    – sa_leinad
    Jul 9 '17 at 12:02

Not the answer you're looking for? Browse other questions tagged or ask your own question.