Just got a new Arduino Uno, accidentally plugged it in before installing the IDE and windows installed its drivers and had it under ports as a generic device on COM3 (it wasn't named Arduino Uno on device manager).

When I installed the IDE, I couldn't upload sketches to the board because it wasn't recognized. So I uninstalled the device from device manager and also the IDE. I pressed the reset button on the Uno, restarted my PC, reinstalled the IDE, then plugged in the Uno. Since then however, the device isn't read by Windows at all; device manager doesn't show it anywhere, nor does it even refresh when plugged in.

I tried this restarting/reinstalling process multiple times, it's also not a cable issue because I checked for that as well. The power LED is still on, and the pin 13 LED is blinking, but the Arduino isn't being recognized.

I've also tried using the Hardware Install Wizard, but that gives me

This Device Cannot Start (Code 10)

I've been trying to run this for a while now.

  • 1
    I'm running Windows 10, and Arduino IDE for more than 6 months now, 2 different systems, and, for me, UNOs always show as a generic USB device, and everything works just fine.
    – KC Tucker
    Commented Jun 8, 2017 at 5:12
  • Last time something similar happened to me, it was caused by a crappy USB cable.
    – KIIV
    Commented Jun 8, 2017 at 6:41
  • If it shows up as a COM port, you can select/program it through the Arduino IDE, what is the problem here?
    – aaa
    Commented Jun 8, 2017 at 6:58
  • you won't see the word "uno" in device manager. do you hear a "ding" when you plug in the Uno?
    – dandavis
    Commented Jun 8, 2017 at 7:02
  • Also try another USB port. Commented Jun 8, 2017 at 9:01

3 Answers 3


You do not need to install drivers in Windows 10 (unless you have a CH340G based Chinese clone, in which case it wouldn't have detected before installing the drivers).

Windows 10 has its own CDC/ACM drivers built in - something every other operating system has had for years and Windows has only just caught up with them. That is why it detected COM3 fine before.

It should have worked fine without installing drivers. It may have been the IDE with the wrong port selected or something else interfering with the port that was stopping you using it.

Uninstall the Arduino drivers and revert to using the Windows built-in ones and work on diagnosing why it wasn't working with those.


You can always remove a unknown device in device manager (yellow exclamation point), reinstall the software, then plug the device in.


If you go to device manager and right-click the Arduino (it will probably have a yellow exclamation mark next to it). You can click update drivers. This fixed the problem for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.