I've just got my first Arduino Pro Mini and a USB to TTL chip. When I try to upload the program I get the message The uploader process failed followed by

avrdude: ser_open(): can't open device "\\.\COM6": Access is denied.

and a bunch of lines like avrdude: ser_drain(): read error: The device does not recognize the command. avrdude: ser_send(): write error: sorry no info avail avrdude: ser_recv(): read error: The device does not recognize the command. avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x48 avrdude: ser_send(): write error: sorry no info avail

with 10 attempts after which nothing comes from avrdude and I can't upload nor get Arduino's visible in port choice menu all the time until the Windows 7 boots again. I can upload to my Arduino Uno with no problems before I try the ttl chip. TTL chip also shows up in the port menu before trying to upload, with correct name next to the port number. I installed drivers I found on a official site that sells the chip that looks just the same as mine, before I did that it wouldn't show up in the port choice menu at all. Is there any way to reset whatever it is that is preventing me from uploading to Arduinos so I don't have to restart my computer every time it happens? I managed to upload one program to the Arduino Pro and it's working fine but after a couple of hours, when I tried again, it didn't work. Maybe it would be of some use to say that I left my pc on sleep with the TTL chip plugged in and powered by the usb. My guess is that this chip is defective and was near it's life end when I uploaded so now it's just confusing the driver to the point where Windows decides to block the driver for the session.

  • Did you try to close arduino IDE and then reopen it? Did you try to unplug the USB-to-TTL converter and plug it again? Did you try close Arduino - unplug - plug again - open Arduino IDE?
    – frarugi87
    Commented Jun 6, 2017 at 9:38
  • @frarugi87 Yes, of course. I've figured out how to fix this and much more, answer coming soon ;) Commented Jun 7, 2017 at 6:55
  • i see this question a lot, so it would be helpful if you could post an answer...
    – dandavis
    Commented Jun 8, 2017 at 6:25
  • @dandavis I posted it that day but for some reason it didn't appear. It should be ok now. Commented Jun 8, 2017 at 18:53

1 Answer 1


After a couple of hours I figured out what was happening so I will write all my analysis here for anyone having some of my problems.

First, a list of my components:

-USB TTL ship, used to upload programs to Arduino Pro. The one on the picture on instructables dot com /id/Usb-to-SerialTTL-adapter/, and used that driver.

-Arduino Pro. Chinese copy, red board just like Sparkfun's. 328p chip @ 5V = 16mhz.

-A board very similar to this one. It has a chip with FT232 written on it, also FTDI in bold letters. usb to ttl

The big USB TTL pcb I was using has 5 output pins: 3v3, 5v, TX, RX, GND. Turns out this is not enough to program Arduino Pro as you need one more pin. If you don't connect this pin, avrdude just gets stuck after opening the COM port and waits indefinitely/until you kill the process. To even be able to see this USB TTL chip in Windows, you need to download a driver from the website(first link) and my guess is that the driver is buggy since it won't exit the process when it encounters this type of error, further leading to suspicious/dangerous behaviour which results in Windows completely shutting down all COM ports until next restart.

To get this pin(it's called DTR/GRN), I borrowed the other chip(3rd) and I connected it regarding to this scheme: https://cdn.sparkfun.com/assets/learn_tutorials/2/6/4/smartbasic_programming.png

I also had to download a different driver for it, I don't remember where I downloaded it from but it's called CDM21226 driver, when you install it it says FTDI driver installed.

Now my uploading was getting stuck no more, however after the first successful upload to my Arduino Pro the upload process would get stuck in the part where it is burning the program, if you turn verbose option in Arduino IDE on, you can see something like Writing: [####### ].

It turns out this driver was faulty too, as I uninstalled it and when I installed it with the very same setup as before it worked seamlessly ever since. It also took me some time how to uninstall a Windows driver without using Device Manager because it wouldn't show up there - no device attached to it.

To do that open Command Prompt as admin and type pnputil.exe -e to get a list of all drivers. Among them will be one called FTDI and that's the guy, in my case he was called oem51.inf. To delete him, type pnputil.exe -d oem51.inf, or add -f before -d to force deletion - in my case it kept saying device is busy so it required this drastic measure. Change 51 to the number you have above your ftdi driver. After this just install the driver again and everything should be fine, even without reboot.

Phew... So much work to get a simple program burned to Arduino Pro. Hope you have less trouble with it than I did.

  • If someone can edit the first link that would be great since I am not allowed to put more than two links in my post :/ Commented Jun 8, 2017 at 18:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.