2

I'm using sublime text for editing and modifying my arduino libraries. Sublime text is pretty pretty, useful and embed a very powerfull plugin system. Someone created an Arduino plugin for it. The compilation function works but the upload doesn't.

I'm trying to upload on an arduino leonardo using Windows 7 x64.

Did anyone tried to fix this problem ?

2
  • 1
    Problem some sort of installation/configuration issue. You are going to have to make an effort to investigate and understand the failure (find error messages, etc which may be being concealed) if you want help with it. Aug 25, 2014 at 16:26
  • @chris Thanks. I was seeing no error messages in the compiler and uploader console, and didn't checked the sublime text console. There were indeed an error !
    – CopperMaze
    Aug 25, 2014 at 17:03

1 Answer 1

2

I finally found it: Problem was solved after commenting those three lines in */Arduino-like IDE/app/uploader.py:

if force_to_reset:
    pre_serial_port = serial_port
    wait_for_upload_port = self.args.get('upload.wait_for_upload_port', 'true') == 'true'
    serial_port = resetSerial(pre_serial_port, self.output_console, wait_for_upload_port)
    # if self.args['cmd'] != 'avrdude':
    #   if serial_port.startswith('/dev/'):
    #       serial_port = serial_port[5:]
    if serial_port:
        for cur_command in self.command_list:
            command_text = cur_command.getCommand()
            command_text = command_text.replace(pre_serial_port, serial_port)
            cur_command.setCommand(command_text)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.