I took an Arduino from a friend yesterday but when I connect it to the laptop there is no light blinking from the Arduino and the laptop doesn't detect any device.

Is there a problem with the Arduino or is there a possibility that the USB has problems?

  • 2
    Try it on other computers. If it works on other computers then it's your laptop's problem. If not then the Arduino or the cable is broken.
    – Bradman175
    Commented Jun 4, 2017 at 7:31
  • I tried on other computers it's the same issue
    – Laya
    Commented Jun 4, 2017 at 7:32
  • So your Arduino or it's cable is either broken. Try with other cables. If it's still broken, you have a busted Arduino and probably need to buy a new Arduino.
    – Bradman175
    Commented Jun 4, 2017 at 7:35
  • Okie I'll try other cables
    – Laya
    Commented Jun 4, 2017 at 7:36

3 Answers 3


Are you sure your laptop doesn't detect any device? It is possible that you need to install right driver for your arduino. The problem could be with:

  1. Cable: Try to replace it with a working cable
  2. Drivers Issue: You need to install driver for your Arduino. Generally, your laptop will issue warnings if it didn't find any appropriate driver for it.
  3. USB-To-UART Bridge: This is an IC in arduino board. It needs to be working for laptop to detect your board.
  4. Microcontroller: Since, you told us that your board is blinking, then microcontroller will be working for sure.

Can you see any part getting hotter? Have you tried with other laptop and cable?

  • The device is not blinking and I have already installed a driver but the problem that when I connect nothing happens not even a blinking light .i am going to try to use my friends USB incase it's the cables problem
    – Laya
    Commented Jun 5, 2017 at 2:40

Adding on to abhiarora's answer, if there are no lights at all on the Arduino, and you verify your cable is outputting power, then you may have shorted the device and need to replace the USB port diode. On my Arduino Nano, this diode is directly under the USB-mini port, on the bottom of the board.

Picture of diode: USB diode (original)

I replaced this on my Arduino Nano with the CDBW0520L-HF from Comchip Technology and the Arduino worked perfectly. (Link provided is from www.arrow.com).

And in case you have a Chinese Arduino Nano like me: USB diode (Chinese)


When you say Arduino, which product specifically are you referring to ? the Arduino UNO ?

Assuming it is the Arduino UNO (or Nano) you will need to first check if it is a genuine Arduino product or a clone (not that there is anything wrong with using a clone). Check your board for a CHIP near the USB port. See if it reads FTDI or CH340. If it reads CH340, then you have a clone. Not to worry, you can still use it as any normal Arduino, you will just need to install the appropriate drivers for the CH340 chip. A simple search for "CH340 driver" can fetch you the right results for your operating system. enter image description here enter image description here

  • Yes I am using the nano
    – Laya
    Commented Jun 9, 2017 at 12:01
  • I already bought a new one if it also doesn't blink and my computer doesn't detect it then I'll do what u suggested ....thanks
    – Laya
    Commented Jun 9, 2017 at 12:02
  • Can you check which chip is used on your existing one ? the FTDI or the CH340 ?
    – PhilipT
    Commented Jun 9, 2017 at 12:12
  • It's CH304 is the chip I am using
    – Laya
    Commented Jun 15, 2017 at 0:16
  • Then i would definitely insist that you try installing the drivers for CH340 and try. The standard arduino drivers that come with the Arduino IDE do not work on CH340 clones. A simple google search should give the drivers for download. If you can't find one that works, let me know and I will provide a source.
    – PhilipT
    Commented Jun 18, 2017 at 17:03

Not the answer you're looking for? Browse other questions tagged or ask your own question.