0

After uninstalling and reinstalling Arduino IDE, my Arduino Uno is not recognized by my PC. When I connect it to my PC all lights are glowing in my board but my PC is not showing anything connected to USB.

When I tried to install drivers manually I'm getting the error device cannot start code 10. I have used the default drivers for Arduino, which I downloaded with the IDE. I tried installing them manually. I don't have any idea about chipset interface whether it is CH or FTDI. I have looked at all the possible solutions but my problem wasn't solved.

drivers image

error

  • I don't do MSWindows but anyhow imagine nobody can answer the question without knowing the interface chip part # (probably starts with FTD or CH) and links to the drivers you tried to install. Please edit your question (click "edit") and add that info – James Waldby - jwpat7 Jun 4 '17 at 21:58
  • I have modified the question with some details. Please help me – rahul bommaraju Jun 5 '17 at 5:20
  • Read the interface chip part # by looking at at your Uno with a magnifier (eg a magnifying glass, a camera, a webcam, etc) then edit the part # into the question. Also, did the board formerly work, and stopped working when you reinstalled the IDE, or did it never work? – James Waldby - jwpat7 Jun 5 '17 at 6:28
  • the board is switching on and orange colored led is also blowing well – rahul bommaraju Jun 5 '17 at 7:11
  • sorry i did not found anything on board which starts with FTD or CH. I'm totally new to arduino and sorry for the inconvenience – rahul bommaraju Jun 5 '17 at 7:26
1

Error code 10 mean Bad Environment. I would guess that you are using the wrong driver, probably 64 bit on a 32 bit OS, etc.

This does not look like a Arduino fault, it looks like a windows Driver fault, so unlplug the board, reboot the PC logon as admin and download the latest drivers for you device and see if that fixes it. You might be able to get better help on a Windows admin forum I think.

  • no I'm using latest drivers for windows 8.1 64 bit and i'm modifying the question with error – rahul bommaraju Jun 5 '17 at 7:56
  • Are you plugging the USB cable from the PC straight into the Arduino? Is it a real Arduino or is it a clone or fake? – Code Gorilla Jun 5 '17 at 9:36
  • i bought it from amazon and it is arduino uno R3 , I'm directly connecting arduino to my pc. Main problem i dentified now is, my PC is not at all responding for that usb,It even not showing usb plugged in but the power is supplying to arduino – rahul bommaraju Jun 5 '17 at 11:57
  • Amazon doesn't mean its real :) docs.microsoft.com/en-us/windows-hardware/drivers/install/… You will need to Google for that error and see. It looks like it could be something simple like a PATH environment problem. You need to look up the rest of the error message and see if that helps. If you can, try a different PC. – Code Gorilla Jun 5 '17 at 12:03
  • Have you tried "Run as admin"? – Code Gorilla Jun 5 '17 at 12:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.