0

I have an Arduino Uno R3 that is simultaneously stuck in DFU mode and won't be recognized as a port in the Arduino IDE on my Macbook Pro (El Capitan). Upon receiving power, the Arduino is automatically in DFU mode (I can use dfu-programmer via Terminal to access it, even though the Arduino is not 'recognized'), and by using the process normally reserved for entering DFU mode (connecting the two pins on the left side of the ICSP) the Arduino actually exits DFU mode. However, by neither entering or exiting DFU mode, the Arduino is still not 'recognized' as a port by the Arduino IDE. Prior to this happening, I had been attempting to flash files to the bootloader with success (I got this same predicament in that process previously once, but I do not know what happened differently).

Thanks, wblegoboy

  • 1
    And have you tried using DFU to reinstall the default CDC/ACM firmware for the ATMega16U2? – Majenko May 30 '17 at 12:50
  • I just tried your suggestion, @Majenko, flashed Arduino-usbserial-atmega16u2-Uno-Rev3.hex and it worked beautifully! My DFU mode is now working properly and my Arduino port is now showing after a restart on my Macbook. Thanks! – wblegoboy May 30 '17 at 13:16
  • Great, I'll put it as an answer then. – Majenko May 30 '17 at 13:21
0

It sounds like your ATMega16U2 has lost its CDC/ACM firmware and is entering DFU mode by default to allow you to install firmware.

Installing the CDC/ACM firmware using dfu-programmer would get it working again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.