0

I'm trying to upload the blink script to my unnamed Arduino-like board. However, the USB port appears to be busy.

This is all the output I get:

Archiving built core (caching) in: /var/folders/43/7_h5zwcs1csdr2dc635m1yq40000gp/T/arduino_cache_942504/core/core_arduino_avr_uno_51f02b7210b938436b779d1c032618e1.a
De schets gebruikt 928 bytes (2%)  programma-opslagruimte. Maximum is 32256 bytes.
Globale variabelen gebruiken 9 bytes (0%) van het dynamisch geheugen. Resteren 2039 bytes voor lokale variabelen. Maximum is 2048 bytes.
avrdude: ser_open(): can't open device "/dev/cu.mydev": Resource busy

I've tried all solutions I could find on internet, but they haven't solved my issue. The main difference with my error and online solutions/errors is that I only have this error. Other people experienced extra errors which enabled the debugging of the problem.

Can anyone help me please?

  • Not nearly enough information to answer this question. Why are you using that particula device, for instance? – SDsolar Jul 3 '17 at 3:46
0

I think my available serial ports were insufficient or something. I installed the ch34* driver which allowed an additional device showing up. Here's the download: http://www.wch.cn/download/CH341SER_MAC_ZIP.html

Then I selected this port and I finally could upload.

  • 1
    If this is the answer, you should not have tagged your question "arduino-uno" as that board does not use a CH34x. The erroneous tag and board description have been removed from your question, so that people with actual Arduino UNO boards do not mistakenly install inappropriate drivers as a result of reading your question/answer. – Chris Stratton May 5 '17 at 21:08
  • 1
    strangely it did solve my issue – Ansjovis86 May 5 '17 at 21:19
  • 1
    If you have some random clone that uses a ch34x rather than the Arduino Uno you originally claimed, potentially it could. But if your board has an ATmega8u2/ATmega16u2 on it, then you are mistaken in thinking this had anything to do with it. – Chris Stratton May 5 '17 at 21:22
  • 1
    Then this answer is wrong, misleading, and should be deleted so that it does not cause others to install inappropriate software, especially software that runs with kernel privileges. – Chris Stratton May 5 '17 at 21:41
  • 1
    I checked the readme file. I got the port by this installer. So this in fact solved my issue. You're right about the Arduino. I checked it on the site of the reseller and they in fact sell clones. So mine is not genuine. Thanks for the help. Would you recommend another solution than installing this ch34 driver, or is this the only way? – Ansjovis86 May 5 '17 at 23:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.