1

I have problem with baud rate. I have changed baud rate of esp from 115200 to 9600 with AT command AT+CIOBAUD. And everything worked fine until I wanted to change it back and executed command AT+CIOBAUD115200, after which everything I send trough arduino IDE serial monitor to ESP I get gibberish. I have tried all baud rated available in serial monitor but got nothing. Wiring stayed the same.

TX -> arduino RX
RX -> arduino TX
GND -> GND
CH_PD -> 3,3V
VCC -> 3,3V

I thought that if I can flash ESP firmware it will get back all default parameters, hence I tried flow these steps (link) but I stopped when executed esptool.py --port /dev/ttyACM0 erase_flash which got me

esptool.py v1.3
Connecting...................

A fatal error occurred: Failed to connect to ESP8266: Invalid head of packet ('\x00')

In some forums is said that to get rid of error I need to change baud rate, but nothings works for me.

Please advise how can I fix this problem.

  • GPIO0 has to be connected to ground to enable programming mode. – Majenko Apr 29 '17 at 23:01
  • Yes, during the flashing GPO0 was connected to ground. – Austris Apr 30 '17 at 6:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.