2

I recently bought an adafruit huzzah as well as a serial to usb cable to connect it to my computer running windows 10. I was able to get the board set up in arduino following the directions found here. I copied and pasted this sketch:

void setup() {
  pinMode(0, OUTPUT);
}

void loop() {
  digitalWrite(0, HIGH);
  delay(500);
  digitalWrite(0, LOW);
  delay(500);
}

into the arduino 1.8.2 IDE, followed these instructions:

Hold down the GPIO0 button, the red LED will be lit

While holding down GPIO0, click the RESET button

Release RESET, then release GPIO0

When you release the RESET button, the red LED will be lit dimly, this means it's ready to bootload

and tried to upload only to get an error:

In versions 1.6.5 and 2.0.0 of the esp library I get these errors:

warning: espcomm_sync failed
error: espcomm_open failed
error: espcomm_open failed

In versions 2.1.0 - 2.3.0 of the esp library, I get these errors:

warning: espcomm_sync failed
error: espcomm_open failed
error: espcomm_upload_mem failed
error: espcomm_upload_mem failed

I've tried switching the tx and rx leads, I've tried versions 1.6.5-2.3.0 of the esp8266 library. I've also tried it on the other board that I ordered and got the same errors. Any ideas on what could be the problem?

EDIT: I've now tried it on a generic esp-01 board and am having the same issue

  • in Arduino IDE, open the serial monitor, click the reset button on the huzzah - do you see anything in the serial monitor - if nothing at all (no text or even garbage characters) then you either: a) have tx/rx connected incorrectly, or b) haven't selected the correct COM port, or c) have a defective huzzah (or you killed it) – Jaromanda X Apr 19 '17 at 0:05
  • aside: if you like the huzzah, checkout the wemos D1 mini (1/2 price) and the nodeMCU (1/3 price) – dandavis Apr 19 '17 at 3:30
  • You may find this helpful: github.com/esp8266/Arduino/blob/master/doc/faq/…. If it solves your problem please come back and write an answer to your question to help others who have the same trouble. – per1234 Apr 19 '17 at 8:08
  • @per1234 I followed the guide and noticed that in my verbose upload output, it's setting the board to nodemcu. Is that normal for a Huzzah? – Jason Apr 20 '17 at 1:38
0

I had to install the SiLabs CP2104 drivers and reboot. Make sure you don't have 2 connection (Arduino IDEs, VS Code with PlatformIO, ...) open. Also, I kept pressing the reset button the first time.

https://learn.adafruit.com/adafruit-feather-huzzah-esp8266/using-arduino-ide

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.