0

Recently, I bought an XBee shield along with a dongle and two XBee's. After assembling them, I tried to connect them using XCTU. Although the XBee on the dongle connected correctly, the computer did not detect the XBee on the shield. I tried switching the XBee's, and there was no difference. I continually an error message telling me to reset the shield. Nothing happens when I reset the shield. Although the computer recognizes that the Arduino is plugged in, it seems as though it doesn't recognize the XBee. I have tried this with every possible configuration, and I keep getting the same message. I have also tried many other things I found online. I have been stuck on this problem for over a week, and any help would be

Here are the materials I am using

2x Series 1 XBee

1x Sparkfun XBee Explorer Dongle

1x Sparkfun XBee Shield

1x Arduino Uno R3

Thanks in advance!

  • Check baud rate and ensure the cable you are using is not just a power only cable. – Visual Micro Apr 13 '17 at 14:54
  • I checked the baud rate, and it still doesn't work. – momiamfine Apr 13 '17 at 22:22
  • Also, the cable seems to have no problem – momiamfine Apr 13 '17 at 22:22
  • Does a different COM port appear when you plug in a shield? For example of both the arduino and the shield are connected do you see two COM ports in xCTU? In windows control panel device manager what is the usb driver name of the shield? – Visual Micro Apr 14 '17 at 15:30
1

Check the baud rate on xctu software, make sure it is on 9600 or you can click on default button and make sure you connect the xbee on the right port enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.