2

I'm trying to connect my Arduino Galileo to Linux via Arduino IDE. Sometimes I'm able to do so, but other times I ge the following error 'Board at /dev/ttyACM0 is not available'. With dmesg I can see that the device is not recognized, a deeper look at this issue led me to find out that a ls on /dev/ttyACM0 shows this:

-rw-r--r-- 1 root root      296 Apr  8 20:14 /dev/ttyACM0

Here I notice that there's a missing 'c' before the permissions that is common to every other /dev/tty*. I would like to know the reason why and if this is the cause for my problem. This seems to be suspicious..or maybe I'm mistaken...please correct me if I'm wrong.

4
  • If "c" is missing then it's a regular file. Probably something tried to open it with the O_CREAT flag without the device being there, and that created the file. You may get some clue as to what it was if you cat the file.
    – Majenko
    Apr 8, 2017 at 19:42
  • @Majenko is there a way to 'revert' it?! Apr 8, 2017 at 19:45
  • 1
    Delete the file, then plug the board in.
    – Majenko
    Apr 8, 2017 at 19:45
  • 1
    Well...it worked! Not sure why, but this /dev/ttyACMO always end up to be a regular file, and I have no clue of what is responsible for it Apr 8, 2017 at 19:52

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.