1

I'm a beginner with Arduino and i have acquired the Arduino UNO R3 board. i have followed the instructions on arduino website in order to install the board, however it fails and still remains as an unrecognised device.

consequently, arduino IDE reports that COM1 is not found, and the 'ports' menu is grayed out.

steps i have tried:

1) install the Arduino 1.0.5 IDE
- the installation failes near the end when installing the arduino board
2) install the Arduino 1.5.7 BETA IDE

- the installation is successful but arduino device is still unrecognized.
3) i have tried manually installing the drivers by letting windows search in the arduino IDE installation folder/drivers/

- it reports that the best driver is already installed - "usb unrecognized device"
4) i have tried installing the drivers by manulally loading the .inf files from the IDE installation folders, and installing all the serial converter A/B/C/D in the list

- all failed to install.

i have done all the above for both IDE 1.0.5 and 1.5.7b with windows installer And zipped files, under administrative rights in windows 8.1

How do i get this to work?

  • Is your board connected to COM1? – Doowybbob Aug 6 '14 at 19:04
  • well thing is, i connect to this board via USB and i honestly dont know what 'port1' is. the windows device manager does not recognize and is unable to install the arduino driver, thus unable to create any ports for it – Banana Aug 6 '14 at 19:06
  • Ah, well then. Does it show up as an unknown device in device manager? – Doowybbob Aug 6 '14 at 19:10
  • yep, it does indeed – Banana Aug 6 '14 at 19:11
  • You said you loaded the .inf files, the guide mentions to just load up Arduino UNO.inf. I'm guessing you tried that? – Doowybbob Aug 6 '14 at 19:14
0

The issue was resolved by changing my USB cable. the cable in the kit was new and seemed to supply power to the arduino board, but windows was unable to identify the board using that cable. maybe the data wires were damaged.
in any case, i changed the cable and everything worked smoothly.

0

To solve this problem.

1. connect your Arduino board to the PC / Laptop. 2. open control panel. and go to view devices and printers

3. Here You can see a unknown device... i.e. your arduino board. double click on it. Unknown device 4 Click on hardware.................................................. Hardware 5. Now Choose Update Driver... Choose the location where the Arduino IDE is installed... And go to Next 6. Now your computer will recognise your arduino board

-4

if you're using USB, it should be connected to COM3 not com1

  • 3
    that does not answer my question (which is now resolved if you bothered to read the comments). and you are wrong, it should be connected to whatever com was created for it. in my case, the IDE was searching for the arduino on com1. – Banana Aug 7 '14 at 16:37
  • When I posted it, there was no 'resolved' comment. – Richik SC Aug 8 '14 at 14:50
  • My "i have solved my issue" comment disagrees with you. – Banana Aug 8 '14 at 14:53
  • @AwesomeByte beat you by 10 minutes but didn't solve your problem. Glad a new cable worked for you, but the cable is fine in my case and I've installed the driver and have the current build of the IDE but the port menu is still greyed out. – Hack-R May 27 '15 at 4:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.