0

I have ESP8266 shield for the Arduido (http://www.ebay.com.au/itm/like/201612329295?chn=ps). It was working but now it's not. I ran the command

AT+UART_DEF=115200, 8, 1, 0, 3

and since running that command the shield only outputs garbled text. I have tried many solutions. These include changing the baud rate to all available rates. Using both an external power supply and an Arduino Uno to power the shield and updating the firmware. Each attempted solution results in the same garbled text accross all baud rates. Have I bricked the chip? Is it possible to recover and set the baud rate back to 9600 as I did when I first set the shield up?

  • ESPs do output a bit of 'garbage' when they start, but I assume you mean it continues. Normally a serial link will only output 'garbled' characters when the receiving end has the baud rate set to high. When the baud is too low it receives nothing. – Code Gorilla Mar 31 '17 at 14:19
  • You should be able to follow any guide on resetting an ESP8266 if you connect directly to the ESP board's serial port. – Code Gorilla Mar 31 '17 at 14:20
  • afaik, you can't brick an ESP8266 by changing settings. – dandavis Mar 31 '17 at 18:54
  • @Matt do you know of any other reason I might be getting garbled text is not baud rate? Before I ran that command I was getting a bit of garbage and the readable text . Now it's all garbage. – Stewart Mar 31 '17 at 21:52
  • @dandavis that was my understanding too however even after flashing the chip with new firmware I still get the same result. – Stewart Mar 31 '17 at 21:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.