2

I have just bought arduino nano board. when i connect the board via usb, system detects the new device but i am not able to select port in arduino ide for writing any code on board. I checked my device manager it says

The drivers for this device are not installed. (Code 28)

There are no compatible drivers for this device.

I have also updated my board and library list in arduino ide.

please help me out?

  • What USB<->uart chip is on the board? Usually on the back (often FTDI, CH340G or CPxxxx). – Paul Mar 30 '17 at 15:42
  • CH340 is on board – Tanmay Yerunkar Mar 30 '17 at 16:13
  • My PCs and Raspberry Pis that I use to program Arduinos all have already had the CH340 driver installed. Vista, Win7, Win8.1, Rpi3B with Raspbian - all worked fine. But it is possible you need to install a driver. I see your answer describes how to do so. Kudos. – SDsolar Mar 30 '17 at 18:02
2

on my nano board CH340G USB<-->uart chip was present, so i installed driver for that chip and everything works fine now. :P

link for the driver (windows 8,10): http://www.arduined.eu/ch340-windows-8-driver-download/

  • Good, looks like you managed to fix the issue yourself! – Paul Mar 30 '17 at 16:54
  • This is good information to have in the stackexchange database. Thank you for posting the link. – SDsolar Mar 30 '17 at 18:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.