7

I had the 12V DC power jack plugged-in all the time, and "to make things more exciting" I also plugged-in the "data" USB whenever I had a new sketch to upload. Is this combination a big no-no, or is my step-up converter to blame?

I am completely new to this stuff but now when thinking of it those 12V from the power jack + 5V from the "data" USB probably violate this clause:
If using more than 12V, the voltage regulator may overheat and damage the board.

  • 2
    Original Arduino boards work fine with both USB and the barrel jack plugged in. However, I think you are having a clone, as the original doesn't use the AMS1117. Depending on what you have connected, the voltage regulator can get quite hot. – Gerben Mar 29 '17 at 7:55
  • @Gerben indeed it is a clone... and given I have ordered an original since this sounds like a promising news to me, thank you very much sir :) – Jaroslav Záruba Mar 29 '17 at 8:22
  • Did you have anything else connected to the 12V DC supply at the same time? – Enric Blanco Mar 29 '17 at 10:51
  • @EnricBlanco nothing else – Jaroslav Záruba Mar 29 '17 at 11:49
5

The "problem" with the AMS1117 voltage regulator is the amount of current they can safely provide drops as the input voltage rises. I'm a Arduino noob, so I looked at the data sheet for the AMS1117 series of voltage regulators. There is a formula: PD=(VIN-VOUT)(IOUT) and Note 2: which says the maximum power dissipation for the SOT-223 package is 1.2 W.

The best case scenario is to use an input voltage of 6.5 volts. (6.5-5)(0.8)=1.2W. This gives you 0.8 amps maximum output. If you use a 12 volt power supply: (12-5)(0.1714)=1.2W. This only gives you 0.1714 amps maximum output.

I'm not sure what kind of power jack you are using, so I'll give you an example of one that I used in a project. It says input 120VAC, output 12VDC, 200ma. The problem is, it actually puts out 20VDC open circuit with no load.

The data sheet gives a maximum input voltage of 15 volts but that would only provide a maximum of 120 mA output.

  • What if I have a 3.7V battery to supply power for a 3.3V ESP8266 (WiFi module)? Would a AMS1117 between the battery and the module be good at making sure the voltage is at ~3.3V? – tgy Feb 8 '18 at 13:42
  • The datasheet for the 3.3V AMS1117 gives a maximum dropout voltage of 1.3V, so 4.6V would be the lowest voltage you should apply to it. Another option is to use the battery with a Buck-Boost DC DC 0.9-6V to 3.3V Step-UP Step-Down Converter Board such as this one: www.aliexpress.com/item/Auto-Buck-Boost-DC-DC-0-9-6V-to-3-3V-Step-UP-Step-Down-Converter/32756017955.html. – VE7JRO Feb 8 '18 at 19:12
1

Probably not. There is nothing fundamentally wrong with what you're doing - it's within the design parameters. In particular:

  • 12V is within the 7-12V recommended range specified for that input. Yes, it means the regulator will get hotter, but the AMS1117 is supposed to be current limited and thermally limited so should just start shutting down if it supplies too much current or gets too hot. As this answer suggests, it would be wise to limit it to 1.2W, which is 171mA. That's plenty for the Arduino itself, so you'd only be running into trouble if you have other peripherals to power.
  • The Arduino Uno has circuitry specifically designed to disconnect the USB's 5V rail if the external power supply is present. This is really only to protect the USB supply from being damaged by the external power supply - the Arduino doesn't care as long as it is getting 5V from somewhere. The USB data function is independent of whether the 5V comes from the USB's 5V rail or the 5V generated from the external supply you provide. The AMS1117 itself, according to its (various) datasheet, has no design susceptibility to an alternate 5V supply being on the output.

Finally, there's an alternate reason for the failure. We've also been using an Arduino Uno clone with the AMS1117, and have also been supplying 5V external (directly to the 5V rail in our case) as well as connecting to USB for programming. We've also had an AMS1117 fail, despite operating everything within normal limits. Our symptoms are that the OUT pin is shorted to the GND pin. Removing the regulator restores full functionality.

Based on various reports around the Internet of suspect behaviour and doubtful provenance of these chips on the clone boards, I would suggest that a faulty IC might be the root cause.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.