0

I'm new to the Arduino world (or the electronics world for that matter).

I have the Arduino Yun and the WifiStatus code works fine (so does the HttpClient). But every time I try to run the bridge sample code, all I see is the pin 13 led light up, and the browser commands don't work.

PS: I have updated the open-wrt to ver. 1.3.

Any thoughts on why this would be happening?

Edit 1:

I have tried to reboot arduino using the hardware switches as well as from the web console. The blink sketch works fine, so does the WifiStatus code and the HttpClient code.

The other problem I face after every few uploads is that the IDE is stuck at "Uploading...". I have tried to give it more time (even an hour). But then I had to unplug it from the Mac and restarted. Then it worked but only for a few times.

But this problem is not specific to the Bridge code. The uploading issue has occurred with other sample code as well. But at least the code worked.

Edit 2:

This is the result from the command ls /dev/tty.*

/dev/tty.Bluetooth-Incoming-Port    /dev/tty.usbmodem1431
/dev/tty.Bluetooth-Modem
  • Welcome to Arduino SE! Can you please edit your questions with more details? Do you have anything connected? Can you add more information about what you've tried, etc? As far as we know, the official code should work. It's really hard to diagnose this without any other information. Does the "blink" sketch work? Does uploading fail? Thanks! – Anonymous Penguin Aug 5 '14 at 18:26
  • when the problem occurs can you open the terminal and post the result of ls /dev/tty.* – geometrikal Aug 6 '14 at 13:47
  • This is the result from the command " /dev/tty.Bluetooth-Incoming-Port /dev/tty.usbmodem1431 /dev/tty.Bluetooth-Modem " – Pranay Joshi Aug 7 '14 at 2:12
1

I ended up doing two things. First I got a replacement hardware. That made the bridge code start working.

And I also changed the port from /dev/tty.usbmodem1431 to /dev/cu.usbmodem1431. As shown in the picture below. That fixed the issue with IDE getting stuck at "Uploading...".

Not sure if this fix will last.

Arduino Tools Menu

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.