3

I am new to Arduino. For the project I am trying to do, I want to install the ESP8266 extension. But the additional boards manager URL option is missing from the Arduino IDE. What should I do to add the extension?

  • 1
    Update to a version that has the option. – Ignacio Vazquez-Abrams Mar 25 '17 at 19:25
  • I just installed the ide 2 days ago . I have the latest one. – ankit Mar 25 '17 at 19:32
  • What version do you have that you think is the latest one? – Majenko Mar 25 '17 at 20:26
  • Version of installed ide is 2:1.0.5+dfsg2-4 – ankit Mar 25 '17 at 20:29
  • 1
    1.0.5 is ancient. – Ignacio Vazquez-Abrams Mar 25 '17 at 21:58
5

You need to download and install a recent version of the Arduino IDE from:

http://www.arduino.cc/en/Main/Software

When you install the Arduino IDE using apt-get you get a very outdated and non-standard version, which does not have the Boards Manager feature. The reason for this is that the license documentation of the Arduino IDE does not currently meet the required standards for the package manager:

https://github.com/arduino/Arduino/pull/2703

0

the URL is the following and the 1.8.2 IDE accepted it: http://arduino.esp8266.com/stable/package_esp8266com_index.json

Good luck, endre

P.s.: I found the answer/URL here: No Response to AT commands

  • this worked....actually this is the correct url – anshulkatta Sep 30 '17 at 12:25
0

You stated in the comments that you are using version 1.0.5. This is a very old version. Go through you computer and make sure you uninstalled any old versions, then try to reinstall the ide.

Make sure you download from arduino.cc, the official location to download the software.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.